Project

General

Profile

Bug #8714

Bug #8059: Windows Camouflage automated tests sometimes failed due to differently ordered icons in the notification area

Step 'Tor is ready' fails randomly

Added by anonym about 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
Start date:
01/16/2015
Due date:
% Done:

100%

Feature Branch:
bugfix/8714-tor-is-ready-robustness
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

... either because:
1. (Wheezy's) GNOME3's hard coded notification timeout of 5 seconds isn't enough for Sikuli to detect the image, or
2. some bug prevents the notification to be shown, e.g. something like #8685.

IMHO we should drop the part where we look for the notification from this step, but put it in a separate "I see the 'Tor is ready' notification" step and test it in a separate scenario.

Associated revisions

Revision 8564daa0 (diff)
Added by Tails developers about 5 years ago

Test 'Tor is ready' notification in a separate scenario (Will-fix: #8714).

Sikuli isn't reliably detecting the notification, either because it
disappears too quickly given Wheezy's GNOME3's hardcoded timeout of
five seconds, or because it fails to show at all. Any way, this often
introduces failure of the 'Tor is ready' step, so this should improve
the robustness of the test suite.

History

#1 Updated by Tails about 5 years ago

  • Status changed from Confirmed to In Progress

Applied in changeset commit:c42ece64c899a0494d09b6e523046c9cc61920aa.

#2 Updated by anonym about 5 years ago

  • Assignee set to kytv
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA

#3 Updated by anonym about 5 years ago

  • Tracker changed from Feature to Bug
  • Feature Branch set to bugfix/8714-tor-is-ready-robustness

#5 Updated by kytv about 5 years ago

  • Assignee deleted (kytv)
  • % Done changed from 50 to 90
  • QA Check changed from Ready for QA to Pass

The changes look good. I've been using this for a few days and from my perspective it's an improvement.

Would merge. :)

#6 Updated by intrigeri about 5 years ago

  • Assignee set to intrigeri

#7 Updated by intrigeri about 5 years ago

  • Status changed from In Progress to 11
  • Assignee deleted (intrigeri)
  • % Done changed from 90 to 100

#8 Updated by BitingBird almost 5 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF