Project

General

Profile

Bug #8694

Upgrade notification to Firefox 4.0.3 in the Unsafe Browser

Added by intrigeri almost 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
01/14/2015
Due date:
% Done:

100%

Feature Branch:
bugfix/8694-disable-unsafe-browser-update-check
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Unsafe Browser

Description

On a fresh Tails 1.2.2 booted from ISO, after starting the Unsafe Browser, I get a notification suggesting me to upgrade to Firefox 4.0.3.


Related issues

Related to Tails - Feature #8702: Write regression test for Unsafe Browser update checks Resolved 01/14/2015

Associated revisions

Revision dd9df5b5 (diff)
Added by Tails developers almost 5 years ago

Disable update checking in the Unsafe Browser. (Will-fix: #8694)

Revision 8f551878
Added by Tails developers almost 5 years ago

Merge remote-tracking branch 'origin/bugfix/8694-disable-unsafe-browser-update-check' into stable (Fix-committed: #8694).

History

#1 Updated by intrigeri almost 5 years ago

  • Assignee set to anonym

#2 Updated by Tails almost 5 years ago

  • Status changed from Confirmed to In Progress

Applied in changeset commit:bc9794d95bbd8a0d627b2c759c1b40b9dc5a3a8e.

#3 Updated by anonym almost 5 years ago

  • Assignee changed from anonym to intrigeri
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA
  • Feature Branch set to bugfix/8694-disable-unsafe-browser-update-check

Fixed in the feature branch.

Note that the I2P Browser is unaffected since it already copies the affected settings from our Tor Browser config. Presumably any update checking would fail any way since they're performed over I2P, and we have no outproxy configured. Whatever.

#4 Updated by anonym almost 5 years ago

  • Related to Feature #8702: Write regression test for Unsafe Browser update checks added

#5 Updated by Tails almost 5 years ago

  • Status changed from In Progress to 11
  • % Done changed from 50 to 100

Applied in changeset commit:e29468783a5ecaee3dcef9352719b70955ebcafa.

#6 Updated by intrigeri almost 5 years ago

  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

#7 Updated by BitingBird almost 5 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF