Project

General

Profile

Bug #8693

Unsafe Browser still does not start (at least in pt-locale)

Added by goupille almost 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
01/13/2015
Due date:
% Done:

100%

Feature Branch:
bugfix/8693-fix-tor-browser-locale-guessing
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Unsafe Browser

Description

a user reported that bug, I reproduced it :

lauch Tails in portuguese, try to lauch the unsafe browser, it never start.

here are the logs :

unzip: cannot find or open , or .
sed: não foi possível ler /tmp/tmp.kIV4zhkPGG/browser/chrome/pt/locale/branding/brand.dtd: No such file or directory

so it really looks like https://labs.riseup.net/code/issues/8158 and https://labs.riseup.net/code/issues/8152, maybe the patch correcting it lost something on its way

Associated revisions

Revision 67c4a51a (diff)
Added by Tails developers almost 5 years ago

Make guess_best_tor_browser_locale() print the exact guessed locale. (Will-fix: #8693)

The rationale is easiest explained with an example: let
LANG="pt_BR.UTF-8". Tor Browser doesn't have a "pt-BR" or even a "pt"
langpack, but it does have a "pt-PT" package, which we want to
use. Firefox is smart enough that it would pick the "pt-PT" package if
we set the useragent to just "pt", which is what we did before.

However, we also want to modify the langpack we're gonna use (to
change the browser name) and we'll use the guessed locale for
that. Since there's no "pt" package, the previous behaviour will fail,
but it works fine if guess_best_tor_browser_locale() prints the exact
locale for some langpack it thinks we should use, so let's do that.

Revision 49645c7c
Added by Tails developers almost 5 years ago

Merge remote-tracking branch 'origin/bugfix/8693-fix-tor-browser-locale-guessing' into stable (Fix-committed: #8693).

History

#1 Updated by goupille almost 5 years ago

forgot to confirm that this is a Tails 1.2.2 issue

#2 Updated by intrigeri almost 5 years ago

  • Assignee set to anonym
  • Priority changed from Normal to Elevated
  • Target version set to Tails_1.2.3
  • Affected tool set to Unsafe Browser

Looks like a regression introduced in 1.2.

#3 Updated by intrigeri almost 5 years ago

I've reproduced it in a fresh 1.2.2, pt_BR locales:

# ls /usr/local/share/tor-browser-extensions/langpack-pt*        
/usr/local/share/tor-browser-extensions/langpack-pt-PT@firefox.mozilla.org.xpi

=> I suspect guess_best_tor_browser_locale is buggy.

#4 Updated by Tails almost 5 years ago

  • Status changed from Confirmed to In Progress

Applied in changeset commit:8cec09d4a0883de9ea41512a23d041df4cc203cb.

#5 Updated by anonym almost 5 years ago

  • Assignee changed from anonym to intrigeri
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA
  • Feature Branch set to bugfix/8693-fix-tor-browser-locale-guessing
  • Type of work changed from Research to Code

intrigeri wrote:

=> I suspect guess_best_tor_browser_locale is buggy.

You are correct. Fixed in the feature branch.

#6 Updated by Tails almost 5 years ago

  • Status changed from In Progress to 11
  • % Done changed from 50 to 100

Applied in changeset commit:558692a33d0852e9467b3e342553ea5745949072.

#7 Updated by intrigeri almost 5 years ago

  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

#8 Updated by BitingBird almost 5 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF