Project

General

Profile

Feature #8673

Feature #5294: Use libguestfs for better disk handling in the test suite

Use ruby-guestfs wherever it's worth it in the automated test suite

Added by intrigeri about 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
Start date:
01/10/2015
Due date:
% Done:

100%

Feature Branch:
test/7822-untrusted-partitions
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

(Depending on the outcome of #8672, common sense, and some good amount of cost/benefits guesses.)


Related issues

Related to Tails - Feature #7822: Finish automating the "use of untrusted partitions" test suite Resolved 08/26/2014
Blocked by Tails - Feature #8672: Evaluate how libguestfs in Jessie supports the usecases we have for it Resolved 01/10/2015

Associated revisions

Revision a4de8847 (diff)
Added by Tails developers almost 5 years ago

Check that only the expected files persist using guestfs (Will-fix: #8673).

... instead of booting Tails and checking it, which takes a long
time. It also feels saner to use a separate method of verifying the
results than the one that was used to make them.

Revision 3fddbf68
Added by Tails developers almost 5 years ago

Merge remote-tracking branch 'origin/test/7822-untrusted-partitions' into devel

Fix-committed: #7822, #8673.

History

#1 Updated by intrigeri about 5 years ago

  • Blocked by Feature #8672: Evaluate how libguestfs in Jessie supports the usecases we have for it added

#2 Updated by Tails almost 5 years ago

  • Status changed from Confirmed to In Progress

Applied in changeset commit:a04c6a8ac1efa24c65ec90d40221277c5ada8206.

#3 Updated by anonym almost 5 years ago

  • Assignee changed from anonym to kytv
  • Target version changed from Tails_1.7 to Tails_1.3
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA
  • Feature Branch set to test/7822-untrusted-partitions

#4 Updated by intrigeri almost 5 years ago

  • Assignee changed from kytv to anonym
  • QA Check changed from Ready for QA to Info Needed

I see the setup instructions modify /usr/lib/guestfs/excludelist, that is shipped by the libguestfs0 package. This is not sustainable, as it will cause problems e.g. on upgrades, so:

  • is this fix in Debian Jessie?
  • if not, is there a bug report and proposed patch about it?

#5 Updated by kytv almost 5 years ago

intrigeri wrote:

I see the setup instructions modify /usr/lib/guestfs/excludelist, that is shipped by the libguestfs0 package. This is not sustainable, as it will cause problems e.g. on upgrades, so:

  • is this fix in Debian Jessie?

I might have had to make similiar changes for Wheezy or Squeeze (it was a long time ago), but I recall that with a future update there was a conflict caused by a update to /usr/lib/libguestfs/excludelist --it included my change and an additional one that I hadn't considered. In any case, that updated package fixed my problem. Again, I don't recall if it was Squeeze or Wheezy, nor do I know if there was a bug filed for it, but it was fixed before I got around to filing one.

If I remember correctly these manual changes were not necessary in my recently built Debian Jessie VM with libguestfs 1:1.28.1-1. If it would help I could set up a new virtual machine to confirm this.

The source for 1:1.28.1-1 doesn't seem to include this file, nor do I see it on my (running) Debian Sid installation, though I installed 1:1.29.6-1 from experimental.

#6 Updated by kytv almost 5 years ago

kytv wrote:

If I remember correctly these manual changes were not necessary in my recently built Debian Jessie VM with libguestfs 1:1.28.1-1. If it would help I could set up a new virtual machine to confirm this.

The modifications to /usr/lib/guestfs/excludelist were not needed in my amd64 Wheezy VM ("release 7.8"). I simply installed libguestfs-tools and "it just worked."

#7 Updated by anonym almost 5 years ago

  • Assignee changed from anonym to kytv
  • QA Check changed from Info Needed to Ready for QA

intrigeri wrote:

I see the setup instructions modify /usr/lib/guestfs/excludelist, that is shipped by the libguestfs0 package. This is not sustainable, as it will cause problems e.g. on upgrades, so:

  • is this fix in Debian Jessie?

Yes, see Debian bug #741203 which I some how had missed before. Also...

kytv wrote:

The source for 1:1.28.1-1 doesn't seem to include this file, nor do I see it on my (running) Debian Sid installation, though I installed 1:1.29.6-1 from experimental.

... since version 1.25.43-2 there's no update-libguestfs-appliance any more:

libguestfs (1:1.25.43-2) experimental; urgency=medium

  * Ship libguestfs0 with supermin 5 appliance in /usr/lib/<multiarch> --
    no more update-libguestfs-appliance
[...]

If I remember correctly these manual changes were not necessary in my recently built Debian Jessie VM with libguestfs 1:1.28.1-1. If it would help I could set up a new virtual machine to confirm this.

I can confirm that it works without issue for me in Debian Jessie.

The modifications to /usr/lib/guestfs/excludelist were not needed in my amd64 Wheezy VM ("release 7.8"). I simply installed libguestfs-tools and "it just worked."

I wonder then why that change is necessary on my Wheezy system then. I have installed some backports, in particular when it comes to the libvirt packages, and wonder if that could be relevant. FWIW I believe I had the same issue 2-3 years ago (when running Wheezy a few months before it was released), but didn't find a solution.

#8 Updated by intrigeri almost 5 years ago

  • Assignee changed from kytv to anonym
  • % Done changed from 50 to 60
  • QA Check changed from Ready for QA to Dev Needed

Found a better solution. anonym is on it.

#9 Updated by anonym almost 5 years ago

  • Assignee changed from anonym to intrigeri
  • QA Check changed from Dev Needed to Ready for QA

#10 Updated by intrigeri almost 5 years ago

  • Assignee changed from intrigeri to kytv

#11 Updated by intrigeri almost 5 years ago

  • Related to Feature #7822: Finish automating the "use of untrusted partitions" test suite added

#12 Updated by Tails almost 5 years ago

  • Status changed from In Progress to 11
  • % Done changed from 60 to 100

Applied in changeset commit:25a805920af67fd35a907a55d96cbffb6a8c9140.

#13 Updated by intrigeri almost 5 years ago

  • Assignee deleted (kytv)
  • QA Check changed from Ready for QA to Pass

#14 Updated by BitingBird almost 5 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF