Project

General

Profile

Feature #8667

Feature #5288: Run the test suite automatically on autobuilt ISOs

Lead a discussion to specify what automatically build ISOs needs to be tested, when and how

Added by bertagaz over 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Continuous Integration
Target version:
Start date:
01/10/2015
Due date:
07/15/2015
% Done:

100%

Starter:
Affected tool:

Description

Organize and lead the discussion to specify a) what kind of built ISO needs to be tested; b) when; c) whether the entire test suite must be run every time; d) how results shall be communicated to developers; e) how long results and corresponding artifacts shall be kept.


Related issues

Related to Tails - Bug #10001: Consider using less CPU-hungry codec for the test suite's --capture option Resolved 08/14/2015
Blocks Tails - Feature #6565: Run the test suite automatically on Git push Duplicate 01/03/2014 10/15/2015

History

#1 Updated by bertagaz over 4 years ago

  • Blocks Feature #6565: Run the test suite automatically on Git push added

#2 Updated by Dr_Whax about 4 years ago

  • Assignee changed from bertagaz to Dr_Whax

#3 Updated by intrigeri about 4 years ago

  • Assignee changed from Dr_Whax to bertagaz

#5 Updated by bertagaz about 4 years ago

  • Priority changed from Normal to Elevated

#6 Updated by bertagaz about 4 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • Blueprint set to https://tails.boum.org/blueprint/automated_builds_and_tests/automated_tests_specs/

Finished the first draft of a blueprint. Will send an email soon to start officially the discussion.

#7 Updated by bertagaz about 4 years ago

  • % Done changed from 10 to 20

#8 Updated by bertagaz about 4 years ago

  • Priority changed from Elevated to Normal

#9 Updated by bertagaz almost 4 years ago

  • Target version changed from Tails_1.4.1 to Tails_1.5

#10 Updated by intrigeri almost 4 years ago

  • Due date set to 07/15/2015

#12 Updated by intrigeri almost 4 years ago

  • Priority changed from Normal to High

#13 Updated by bertagaz almost 4 years ago

  • Target version changed from Tails_1.5 to Tails_1.6

Not finished yet, postponing.

#14 Updated by intrigeri almost 4 years ago

Not finished yet, postponing.

Waiting might not work. I suggest pinging the relevant people, and stating your deadline.

#15 Updated by bertagaz almost 4 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 20 to 100

Seems we discussed everything and the blueprint is in good shape enough.

#16 Updated by bertagaz almost 4 years ago

  • Assignee deleted (bertagaz)

#17 Updated by intrigeri almost 4 years ago

Re-read it, looks good indeed! Added 7868269 on top. I'm now going through the thread on -dev@.

#18 Updated by intrigeri almost 4 years ago

  • Related to Bug #10001: Consider using less CPU-hungry codec for the test suite's --capture option added

#19 Updated by intrigeri almost 4 years ago

  • Status changed from Resolved to In Progress
  • Assignee set to bertagaz
  • % Done changed from 100 to 90

Reopening as I don't agree with the proposal for (not) storing videos. I'm sorry that a 48 hours deadline during a week-end was not long enough for me.

#20 Updated by bertagaz almost 4 years ago

  • Assignee changed from bertagaz to intrigeri
  • QA Check set to Info Needed

intrigeri wrote:

Reopening as I don't agree with the proposal for (not) storing videos. I'm sorry that a 48 hours deadline during a week-end was not long enough for me.

So this video thing has been discussed and the design doc has been updated.

The remainings of this discussion are related to the redmine notifications, which is a should in the design doc, so not a blocker for this ticket I believe (specially since you volunteered to update the doc yourself). No urge still.

#21 Updated by intrigeri almost 4 years ago

  • Assignee changed from intrigeri to bertagaz

The remainings of this discussion are related to the redmine notifications, which is a should in the design doc, so not a blocker for this ticket I believe

So this ticket can be closed, I think :)

(specially since you volunteered to update the doc yourself).

Oops, did I? :) We'll see once we've decided something, I guess.

#22 Updated by bertagaz almost 4 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (bertagaz)
  • % Done changed from 90 to 100
  • QA Check changed from Info Needed to Pass

intrigeri wrote:

So this ticket can be closed, I think :)

\o/

We'll see once we've decided something, I guess.

Yes, I tried but have hard time to wrap all this thread in my mind atm. No pressure on this anyway.

Also available in: Atom PDF