Project

General

Profile

Feature #8655

Feature #6196: Build all active branches

Lead the discussion to specify what kind of branch needs to be automatically built, and when

Added by intrigeri almost 5 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Continuous Integration
Target version:
Start date:
01/09/2015
Due date:
06/01/2015
% Done:

100%

Starter:
Affected tool:

Description

  • which branches?
  • daily/post-commit?

Related issues

Related to Tails - Feature #9615: Consider notifying both committer and author for development branches Rejected 06/18/2015
Blocks Tails - Feature #8657: Write library code that implements the branch to build parameters mapping Resolved 01/09/2015 07/15/2015

History

#1 Updated by intrigeri almost 5 years ago

  • Blocks Feature #8656: Write code that generates a set of Jenkins jobs for all branches we want to automatically build added

#2 Updated by intrigeri almost 5 years ago

  • Category changed from Infrastructure to Continuous Integration

#3 Updated by intrigeri almost 5 years ago

  • Blocks deleted (Feature #8656: Write code that generates a set of Jenkins jobs for all branches we want to automatically build)

#4 Updated by intrigeri almost 5 years ago

  • Blocks Feature #8657: Write library code that implements the branch to build parameters mapping added

#5 Updated by bertagaz almost 5 years ago

  • Due date set to 02/24/2015
  • Target version changed from Tails_1.4 to Tails_1.3

#6 Updated by bertagaz almost 5 years ago

  • % Done changed from 0 to 10
  • Blueprint set to https://tails.boum.org/blueprint/automated_builds_and_tests/autobuild_specs/

Add a blueprint, thread started on tails-dev@

#7 Updated by bertagaz almost 5 years ago

  • Status changed from Confirmed to In Progress

#9 Updated by Dr_Whax over 4 years ago

  • Target version changed from Tails_1.3 to Tails_1.3.2

This discussion is still ongoing. Postponing to 1.3.1

#10 Updated by Dr_Whax over 4 years ago

Waiting for input from anonym

#11 Updated by intrigeri over 4 years ago

What's the status here? Is there any pending discussion or remaining blocker?

#12 Updated by intrigeri over 4 years ago

Ping?

#13 Updated by bertagaz over 4 years ago

  • Assignee changed from Dr_Whax to bertagaz
  • Target version changed from Tails_1.3.2 to Tails_1.4

#14 Updated by intrigeri over 4 years ago

  • Target version changed from Tails_1.4 to Tails_1.4.1

Postponing.

#16 Updated by intrigeri over 4 years ago

  • % Done changed from 10 to 70

Apart of some leftovers of the discussion wrt. notifications (just replied to it on -dev@), I think we're done here.

#17 Updated by intrigeri over 4 years ago

intrigeri wrote:

Apart of some leftovers of the discussion wrt. notifications (just replied to it on -dev@), I think we're done here.

Looks like those leftovers were taken care of, eventually. Can we call this done, or?

#18 Updated by bertagaz over 4 years ago

I'm not sure they are, have a look at this last email

#19 Updated by intrigeri over 4 years ago

I'm not sure they are, have a look at this last email

OK... oh well, there seemed to be a consensus months ago, and the resulting spec has been implemented, so IMO this specific idea of refining notifications can be postponed, tracked by a dedicated ticket, and thus this one can be closed.

#20 Updated by bertagaz over 4 years ago

  • Related to Feature #9615: Consider notifying both committer and author for development branches added

#21 Updated by bertagaz over 4 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (bertagaz)
  • % Done changed from 70 to 100

intrigeri wrote:

I'm not sure they are, have a look at this last email

OK... oh well, there seemed to be a consensus months ago, and the resulting spec has been implemented, so IMO this specific idea of refining notifications can be postponed, tracked by a dedicated ticket, and thus this one can be closed.

Ack, that'd mean quite a change to our current design and deployment. I've created 9615 to track the state of this refinement idea. We'll see once running live.

#22 Updated by sajolida over 4 years ago

  • Due date changed from 02/24/2015 to 06/01/2015

Also available in: Atom PDF