Project

General

Profile

Feature #8636

Feature #6196: Build all active branches

Deploy our Puppet recipes for Jenkins from scratch

Added by Dr_Whax about 5 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Infrastructure
Target version:
Start date:
01/09/2015
Due date:
02/28/2015
% Done:

100%

Feature Branch:
Type of work:
Contributors documentation
Blueprint:
Starter:
Affected tool:

Description

The objective is to have our current Jenkins setup easy to replicate and document on how to do so.

History

#1 Updated by Dr_Whax about 5 years ago

I'll get an introduction on how to deploy this soon(asap).

#2 Updated by intrigeri about 5 years ago

  • Related to Feature #6922: Document how to replicate parts of our infrastructure for local testing added

#3 Updated by intrigeri about 5 years ago

  • Subject changed from Deploy our jenkins puppet recipes from scratch to Deploy our Puppet recipes for Jenkins from scratch

#4 Updated by bertagaz about 5 years ago

  • Target version set to Tails_1.3

#5 Updated by bertagaz about 5 years ago

  • Related to deleted (Feature #6922: Document how to replicate parts of our infrastructure for local testing)

#6 Updated by bertagaz about 5 years ago

  • Parent task set to #6196

#7 Updated by bertagaz about 5 years ago

  • Blocked by Feature #6922: Document how to replicate parts of our infrastructure for local testing added

#8 Updated by Dr_Whax about 5 years ago

We're thinking of adding this to the following page: https://tails.boum.org/contribute/working_together/roles/sysadmins/

Or do we want another page for this? /roles/ci-team/ ?

#9 Updated by bertagaz about 5 years ago

Are you talking about the documentation about how to deploy parts of our infra?

In this case, I guess this is ticket #6922 then.

#10 Updated by intrigeri about 5 years ago

I think this was completed. Wasn't it?

#11 Updated by Dr_Whax about 5 years ago

Yes, we have deployed 2 vm's!

#12 Updated by intrigeri about 5 years ago

Yes, we have deployed 2 vm's!

So... why is this ticket still open?

#13 Updated by Dr_Whax about 5 years ago

  • % Done changed from 0 to 100

I put done to 100%. I can't choose the status with resolved, only with fix committed. Is this sufficient for now?

#14 Updated by intrigeri about 5 years ago

I put done to 100%. I can't choose the status with resolved, only with fix committed.

... because this ticket is marked as blocked by #6922, which has Confirmed status. Given that you apparently managed to resolve #8636 without #6922 being fixed first, that relationship seems to be buggy. So please delete it and close this ticket, otherwise we'll be twisting Redmine semantics in confusing way.

#15 Updated by bertagaz about 5 years ago

  • % Done changed from 100 to 80

I believe we haven't really finished this task, we still have one final last step to have this deployment in a working state (deploying a local Tails git clone and hook it into jenkins to trigger builds on changes).

Regarding #6922, the relationship between the 2 tickets makes sense. It is being worked on, but I'm unsure of when it will be finished, in the coming week if everything goes fine.

This tickets are not really blockers for the 1.3 release anyway, this milestone was mainly there to be an indication and they can be delayed a bit.

#16 Updated by intrigeri about 5 years ago

Thanks for the explanation :)

[...] this milestone was mainly there to be an indication and they can be delayed a bit.

Fair enough.

#17 Updated by Dr_Whax about 5 years ago

This work will be finished at the end of the upcoming week. No mercy!

#18 Updated by Dr_Whax almost 5 years ago

  • Due date changed from 01/30/2015 to 02/28/2015
  • Target version changed from Tails_1.3 to Tails_1.3.2

Made good progress on this today, minor bug remaining.

#19 Updated by BitingBird almost 5 years ago

  • Status changed from Confirmed to In Progress

#20 Updated by Dr_Whax almost 5 years ago

Alright, we have a build working. If the build finishes successfully, I declare this ticket as resolved.

#21 Updated by intrigeri almost 5 years ago

Alright, we have a build working. If the build finishes successfully, I declare this ticket as resolved.

Good, it means that our Puppet stuff is starting to be good enough that one can replicate it given enough hand-holding!

Hence, I don't see why this ticket could be marked as resolved yet, for the same reasons that we discussed two weeks ago on this very ticket. Did I miss anything?

(Details: my understanding of the relationship between this ticket and #6922 (that I asked to be clarified 2 weeks ago, and then bertagaz confirmed to make sense in #8636#note-15) is that the idea was to write doc (#6922), and then use this from scratch deployment (#8636) to validate both the doc and the Puppet code. So, it seems that we've now validated the Puppet bits, but not the doc yet -- since it doesn't exist.)

#22 Updated by Dr_Whax almost 5 years ago

  • Assignee changed from Dr_Whax to bertagaz

We have deployed a fully working Jenkins installation, which has build an Tails ISO. The resulted Tails ISO booted in a KVM system just fine.

Assigning to Bertagaz for the documentation.

#23 Updated by BitingBird almost 5 years ago

  • Type of work changed from Sysadmin to Contributors documentation

#24 Updated by bertagaz almost 5 years ago

  • Blocked by deleted (Feature #6922: Document how to replicate parts of our infrastructure for local testing)

#25 Updated by bertagaz almost 5 years ago

  • Target version changed from Tails_1.3.2 to Tails_1.4

#26 Updated by intrigeri almost 5 years ago

  • Target version changed from Tails_1.4 to Tails_1.4.1

Postponing.

#28 Updated by bertagaz over 4 years ago

  • Target version changed from Tails_1.4.1 to Tails_1.5

#29 Updated by bertagaz over 4 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (bertagaz)
  • % Done changed from 80 to 100

I think I've been confused with #6922, which is the doc part I wanted to add.

So this ticket can be considered closed as we did deploy it!

Also available in: Atom PDF