Project

General

Profile

Feature #8602

Feature #7649: Include a grsecurity-patched kernel

Compare Debian kernel configuration with the one used in spender's grsec build service

Added by intrigeri almost 5 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
01/07/2015
Due date:
% Done:

0%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Description

It would be good to know if spender's kernels differ from Debian's one only for options introduced by the grsec patchset, or more deeply.


Related issues

Related to Tails - Feature #8600: Evaluate a grsec kernel from spender's build service in Tails Rejected 01/07/2015

History

#1 Updated by intrigeri almost 5 years ago

  • Related to Feature #8600: Evaluate a grsec kernel from spender's build service in Tails added

#2 Updated by Dr_Whax over 4 years ago

I have a conflict on Debian Wheezy with spender's .deb 3.2.64 kernel build:

linux-headers-3.2.64-grsec : Depends: libc6 (>= 2.14) but 2.13-38+deb7u8 is to be installed

I don't have any issues on Debian Jessie however.

#3 Updated by intrigeri over 4 years ago

I have a conflict on Debian Wheezy with spender's .deb 3.2.64 kernel build:

linux-headers-3.2.64-grsec : Depends: libc6 (>= 2.14) but 2.13-38+deb7u8 is to be installed

Looks like those packages were not properly built in a clean Wheezy chroot...
But anyway, that's off-topic here: one can compare kernel configuration without actually installing the package.

#4 Updated by intrigeri almost 4 years ago

  • Status changed from Confirmed to Rejected

Now that grsec landed in Debian, I guess this is not relevant anymore. Sorry if I got it wrong!

Also available in: Atom PDF