Project

General

Profile

Feature #8586

Create a directory of organizations doing Tails training

Added by intrigeri almost 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
01/07/2015
Due date:
% Done:

100%

Feature Branch:
contrib/8586-training
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:

Description

We, as the Tails project, don't do training. Quite a few other organizations do. Various discussions, including support on the #tails channel, show that potential users have a hard time finding an organization that could help them. We could create and maintain a list of organizations that do Tails training. For each such organization, we would need contact information and target audience.


Related issues

Related to Tails - Bug #10062: List more organizations doing Tails trainings Resolved 08/19/2015

Associated revisions

Revision 904bcf9d
Added by sajolida about 4 years ago

Merge branch 'contrib/8586-training' (Closes: #8586)

History

#2 Updated by BitingBird almost 5 years ago

I suggested it, so I'm all for it :)

#3 Updated by sajolida over 4 years ago

During the 201503 meeting we agreed that the Tails homepage should contain such a list, under the following conditions:

  • We note that the list is not exhaustive.
  • We keep in touch with the organizations listed and for each organization we need someone committed to update the page.
  • We make the target audience clear and get the agreement of the org before adding them. This is important to make sure, that organizations aren't overrun by interested parties.
  • We try not to duplicate work of other organizations.

#4 Updated by intrigeri over 4 years ago

  • Type of work changed from Discuss to End-user documentation

#6 Updated by BitingBird over 4 years ago

  • Assignee set to BitingBird

#7 Updated by BitingBird over 4 years ago

  • Target version set to Tails_1.4

#8 Updated by BitingBird over 4 years ago

  • Status changed from Confirmed to In Progress
  • Feature Branch set to bitingbird:contrib/8586-training

#9 Updated by BitingBird over 4 years ago

  • % Done changed from 0 to 20

Made a first version, listed the only ones that answered yet. The page structure can be commented on already, but we're not going to publish it until we have a bit more to list, so no hurry :)

I linked the new "Teach" page from contribute (under "speaker", it seemed the more appropriate).

#10 Updated by BitingBird over 4 years ago

There are now 2 organizations on the list. I hope a few others answer soon, seems like it could be published this month :)

#11 Updated by BitingBird over 4 years ago

  • Assignee changed from BitingBird to sajolida
  • QA Check set to Ready for QA

Removed the individual, added one more org. The list is now 3 orgs, I think we could publish it and it would probably incite more to manifest themselves (we lack more generic orgs, regular lessons for regular people).

Please review :)

#12 Updated by BitingBird over 4 years ago

I'll try to reach out to the list of orgs listed there to add more: https://github.com/RaReNet/DFAK/blob/master/SecureCommunication.md and also Freedom of the Press

#13 Updated by sajolida over 4 years ago

  • Assignee changed from sajolida to BitingBird
  • QA Check changed from Ready for QA to Dev Needed

Thanks for working on this.

Your list is a good start. But I'm not sure is whether this should go under /contribute or under /support. We are listing those organizations because we think that this is valuable information to our users looking for specific help and direct training. With this in mind why not put that under support? I understand that doing training is a way of contributing to Tails as well, but that's not where the people who need this info will be looking for it. Then we can also have a pointer from
contribute to that page.

Could you propose something to have this integrated in /support instead and pointed from /contribute?

#14 Updated by sajolida over 4 years ago

Ah, and something else: do you think that organization doing other kind of support than technical training could go there as well? Or shall we do a different thing for those?

#15 Updated by BitingBird over 4 years ago

I think support would be ok too, as long as there is a link from contribute. I'll move the page.

I don't see what you mean about "other kind of support than technical training". What kind of support would that be? Answering questions? Developing code to resolve problems? Installing Tails for you?
Right now, the page is called "teach", I guess we can rename it, but we should think beforehand what type of support we'll welcome there, because it could become big and varied...

#16 Updated by sajolida over 4 years ago

What kind of support would that be?

From the top of my head:

  • Media support
  • Emotional or psychological support
  • Financial support
  • Legal support
  • Physical protection

All this could be of great help to some of our users and might be
provided by some of those organizations or others. Still, I wouldn't go
too wild and maybe start with a strong list of organizations that do
technical support but also mention if they do other kind of support.

#17 Updated by BitingBird over 4 years ago

I don't really see what this has to do with Tails, why users would search in Tails to find those, and the specific cases in which those kind of support would be available probably depends a lot of the country, the situation of people etc. I think we should keep to what's related to Tails, i.e. technical support regarding Tails, and let users explore the websites (we give the links) to see for themselves if they provide something else that they need. We can put this to discuss on next contirbutors meeting, if we dont agree, to get more input on it ?

#18 Updated by BitingBird over 4 years ago

  • Assignee changed from BitingBird to sajolida
  • QA Check changed from Dev Needed to Info Needed

#19 Updated by sajolida over 4 years ago

  • Assignee changed from sajolida to BitingBird
  • Target version deleted (Tails_1.4)
  • QA Check changed from Info Needed to Dev Needed

I don't really see the problem in extending your current description of each organization to include other possible kinds of support. But I won't insist more and I'm fine with not including that.

#20 Updated by BitingBird over 4 years ago

  • Target version set to Tails_1.5

#21 Updated by BitingBird over 4 years ago

  • Assignee changed from BitingBird to sajolida
  • % Done changed from 20 to 50
  • QA Check changed from Dev Needed to Ready for QA

Moved to support, linked from contribute. Please review :)

#22 Updated by sajolida over 4 years ago

  • Target version deleted (Tails_1.5)

#23 Updated by BitingBird over 4 years ago

  • Target version set to Tails_1.6

#24 Updated by sajolida over 4 years ago

  • Assignee changed from sajolida to BitingBird
  • QA Check changed from Ready for QA to Dev Needed
  • Feature Branch changed from bitingbird:contrib/8586-training to contrib/8586-training

Thanks for the nice branch. It looks really appropriate in the support section and the list is formatted nicely. I pushed some improvements on top of your work, so please review 207b559..ae5c072.

Now I have a few more comments to further improve it before merging:

  • Can you try to create an inline to deduplicate the intro sentence of both sections? I changed the one on /support quite a bit but didn't improve the one on /support/learn.
  • I'm wondering whether your new section is at the best possible place on the support page. Now it's below the two blocks for "Report a problem" and "Request a feature" and looks like part of it. Maybe it could advantageously moved earlier on the page, maybe before "Upgrade" or "FAQ" as it it more generic than problem solving.
  • Could we like to the public key of Access instead of providing their fingerprint. First that would be more helpful, second I don't want to provide fingerprints of others on our website and let the users trust us or our website instead of verifying it themselves. Maybe we can find an HTTPS link on their website?
  • Use "OpenPGP" instead of "PGP". Access Now probably doesn't use the commercial PGP software.
  • Did you decide something on how to order the list of organization. Shall we sort them by alphabetical order of their name? Of course, right now that's a bit ridiculous but I hope this list will grow quite a bit.

Other than that I'm ready to merge the page and make it public. But I think there are still some low-hanging fruits that could be added to this list quite easily. Did you wrote Sanne and Emma Peel about that? For example, Also I'm surprised not to have Tactical Tech or Café Vie Privée on this list that we both met in Paris last year.

#25 Updated by BitingBird over 4 years ago

  • tried creating an inline, still building to see if I did that correctly :)
  • Moved the paragraph above FAQ as suggested
  • they don't provide their openPGP key on their website, they only have a contact form. Added a link to it. Providing the fingerprint allows people to have the full ID to download it from the keyservers...
  • corrected PGP
  • sorted in alphabetical order

Yes, I should contact (and add) many more organizations, but I wanted to agree on the form of the page - those are two different issues :)
We could always publish it as-is, that's already a bit of information for users, and I'll add more afterwards (it will also be easier to explain to people when providing a link, saying "do you want to be added to that page?").

#26 Updated by BitingBird over 4 years ago

  • Assignee changed from BitingBird to sajolida
  • % Done changed from 50 to 60
  • QA Check changed from Dev Needed to Ready for QA

The inline looks fine. Please review again :)

#27 Updated by sajolida over 4 years ago

  • Assignee changed from sajolida to BitingBird
  • You managed to do the inline correctly! Still, I renamed the file to have a .mdwn extension. I'm worried about translations to break if the file has no extension, though I didn't check.
  • I also rescued a shorter version of the introduction sentence that you deleted with 36c7a99. See my 3adb022.
  • I agree with your reasoning on the OpenPGP fingerprint.
  • And thanks for doing small commits!

I think this branch is ready to be merged, unless you disagree with 36c7a99.

After that, do you want to keep on working on this ticket to add more organizations or do you prefer creating a different ticket?

#28 Updated by BitingBird about 4 years ago

  • Assignee changed from BitingBird to sajolida
  • % Done changed from 60 to 90
  • QA Check changed from Ready for QA to Pass

I'm fine with your change, youhou this is ready to merge :)

I prefer that we close this ticket, who was about the form of the page in general and is solved, and I'll open another one to add more.

Cheers :)

#29 Updated by BitingBird about 4 years ago

  • Related to Bug #10062: List more organizations doing Tails trainings added

#30 Updated by sajolida about 4 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 90 to 100

#31 Updated by sajolida about 4 years ago

  • Assignee deleted (sajolida)

#32 Updated by BitingBird about 4 years ago

Youhou :)

Also available in: Atom PDF