Project

General

Profile

Bug #8574

Bug #8573: Hopefully replace Pidgin some day

Test CoyIM in Tails

Added by intrigeri almost 5 years ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
01/07/2015
Due date:
% Done:

100%

Feature Branch:
Type of work:
Test
Starter:
Affected tool:
Instant Messaging


Subtasks

Feature #8575: Wait for someone to write a GUI on top of xmpp-clientResolvedsycamoreone

Feature #8576: Ask for IRC support in xmpp-clientResolvedsycamoreone


Related issues

Duplicated by Tails - Feature #15147: CoyIM Duplicate 01/05/2018

History

#1 Updated by intrigeri almost 5 years ago

  • Assignee changed from intrigeri to sycamoreone

#2 Updated by sycamoreone almost 4 years ago

  • Subject changed from Wait for xmpp-client to be a suitable Pidgin replacement to Wait for CoyIM to be a suitable Pidgin replacement

#3 Updated by sajolida almost 4 years ago

  • Description updated (diff)

#4 Updated by Kurtis about 3 years ago

CoyIM, in three different github issues, have stated that they have absolutely no intention of adding OMEMO support.

https://github.com/twstrike/coyim/issues/364
https://github.com/twstrike/coyim/issues/233
https://github.com/twstrike/coyim/issues/199

This suggests to me that Coy isn't as good of an option as Gajim, since gajim already has an OMEMO plugin in the debian sid repo: https://packages.debian.org/sid/gajim-omemo

It'd be different if Coy said that OMEMO support was on their roadmap.

#5 Updated by intrigeri almost 2 years ago

#6 Updated by u almost 2 years ago

  • Blueprint set to https://tails.boum.org/blueprint/replace_Pidgin/

CoyIM is in Debian and maintained by Sascha Steinbiss.

#7 Updated by u almost 2 years ago

@sycamoreone: do you still intend to work on this?

Let's try to outline the next steps to be taken.
- To me it seems one blocker is that CoyIM has not been audited. > we could try to help find someone to audit this piece of software.
We should try to test it in Tails.
- Reverify that it suits our requirements (I think it does), see blueprint.
- It will also require many Go libraries to go into Tails (I don't think we ship those yet, but I'm not sure).

#8 Updated by intrigeri over 1 year ago

  • Assignee changed from sycamoreone to Dr_Whax

DrWhax, it looks like sycamoreone won't work on this again. I see you're on the team for the parent ticket so perhaps you want to take over this task once #11686 is done?

#9 Updated by intrigeri over 1 year ago

  • Blocked by Bug #11686: Replace Pidgin: refine blueprint added

#10 Updated by u over 1 year ago

  • Type of work changed from Wait to Test

Next step: test coyim in Tails. Are you interested in doing that, Drwhax? If not please unassign yourself.

#11 Updated by u over 1 year ago

  • Subject changed from Wait for CoyIM to be a suitable Pidgin replacement to Test CoyIM in Tails

#12 Updated by intrigeri over 1 year ago

u wrote:

- To me it seems one blocker is that CoyIM has not been audited.

It's not a blocker IMO unless other candidates have been, which I doubt. CoyIM is written by very security-conscious people, with security in mind right from the beginning. I doubt one can tell the same about most of the other candidates.

- It will also require many Go libraries to go into Tails

This is incorrect "thanks" to Go programs being built with static linking. On Tails 3.9~rc1 CoyIM can be installed without pulling any extra dependency in :)

#13 Updated by intrigeri over 1 year ago

  • Blocked by deleted (Bug #11686: Replace Pidgin: refine blueprint)

#14 Updated by intrigeri over 1 year ago

I've quickly tested it in Tails 3.9~rc1 (CoyIM 0.3.7-3) and I like it! The XMPP account setup process is way simpler than in Pidgin, e.g. no need to specify the connect server (at least for a riseup.net XMPP account) despite our lack of SRV DNS support, and basically I'm only asked for the info that's truly needed while Pidgin is obviously trying to confuse me by making me wonder whether the 20+ default settings will work for my account or maybe I should customize the 17th one. The initial OTR setup also feels less clunky (no dialog popups).

Problems:

  • The fact links are not clickable is probably a conscious security decision, but it does impact usability. I know that the CoyIM team has done some usability testing so I'd be curious to know how that fared. Not a blocker IMO because UX is so much better generally.
  • The "minimum time between notifications" pref does not seem to have any effect. Reproduced with the latest version that's in testing/sid (0.3.8+ds-5+b1). But Pidgin has no such option anyway so it's not a blocker.

So I'm closing this ticket as resolved. My feeling is that if we ever manage to finish the discussion about IRC (tl;dr: is XMPP+OTR good enough for the default chat client in Tails or do we insist on keeping IRC support for nerds?), CoyIM is a pretty strong candidate.

#15 Updated by intrigeri over 1 year ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (Dr_Whax)

#16 Updated by intrigeri over 1 year ago

Oh, and it supports importing accounts from Pidgin, which can be a game changer in the context of Tails.

#17 Updated by segfault about 1 year ago

I just tested CoyIM on Debian and I can't find a way to join a chat room. I also can't find any documentation.

Also available in: Atom PDF