Project

General

Profile

Feature #8560

Feature #7544: Have a multiplatform Installer

Feature #8559: Make Tails Installer work on OS X

Study feasibility of porting Tails Installer to OS X

Added by intrigeri almost 5 years ago. Updated almost 2 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Installation
Target version:
-
Start date:
01/06/2015
Due date:
% Done:

0%

Feature Branch:
Type of work:
Research
Starter:
Affected tool:
Installer

Related issues

Related to Tails - Feature #8558: Study feasibility of porting Tails Installer to Windows Resolved 06/22/2015
Related to Tails - Feature #8802: Investigate graphical tools for manual installation on Mac Resolved 02/04/2015
Related to Tails - Bug #11668: Install on Mac: test Entreprise Rejected 08/19/2016

History

#1 Updated by intrigeri almost 5 years ago

  • Related to Feature #8558: Study feasibility of porting Tails Installer to Windows added

#3 Updated by sajolida almost 5 years ago

  • Related to Feature #8802: Investigate graphical tools for manual installation on Mac added

#4 Updated by sajolida almost 5 years ago

While working on #8583, we got quite worried about the bootstrapping process for Mac. USB installation is currently only possible through the command line, and DVD drives are disappearing from recent Mac. So the situation for Mac is quite bad.

Would it be possible to do that feasibility study (maybe partly) quite early in 2015? Because if we realize that porting to Mac is easier than porting to Windows or easier that we thought we might want to move faster on this. I understand that we might need to recruit external people to do the implementation work...

#5 Updated by intrigeri almost 5 years ago

While working on #8583, we got quite worried about the bootstrapping process for Mac.
USB installation is currently only possible through the command line, and DVD drives
are disappearing from recent Mac. So the situation for Mac is quite bad.

I've been told that diskutil (sic?) on OSX allows one to do the same thing as dd, but in a GUI. Once we ship a hybrid ISO, this means the bootstrap can be done without the command line, and in turn this very ticket becomes not so much of an emergency as it currently seems to be.

#6 Updated by sajolida almost 5 years ago

Right, if we can use Disk Utility, then this becomes as urgent as the port to Windows.

#7 Updated by sajolida almost 4 years ago

  • Target version set to Tails_2.0

#8 Updated by intrigeri almost 4 years ago

https://github.com/twstrike/gtk-mac-bundler might be useful for this (or not).

#9 Updated by intrigeri over 3 years ago

  • Target version changed from Tails_2.0 to Tails_2.2

(Tails 2.0 was released and I'd like to close the corresponding target version in Redmine accordingly.)

#10 Updated by intrigeri over 3 years ago

  • Blueprint set to https://tails.boum.org/blueprint/Port_Tails_Installer_to_OS_X/

#11 Updated by sajolida over 3 years ago

  • Assignee deleted (u)
  • Target version deleted (Tails_2.2)

This was reported as a failure, so deassigning from you to clean your plate. You can relax now :)

#13 Updated by elouann about 3 years ago

  • Related to Bug #11668: Install on Mac: test Entreprise added

#14 Updated by intrigeri almost 2 years ago

  • Status changed from Confirmed to Rejected

The output of #11679 is that we'll instead work on #15292.

Also available in: Atom PDF