Project

General

Profile

Feature #8556

Feature #7544: Have a multiplatform Installer

Feature #8549: Have Tails Installer in Debian and Ubuntu

Feature #8557: Have Tails Installer uploaded and accepted into Debian

Feature #8561: Adapt Tails to the Installer rename

Feature #8562: Write manual test suite for the Tails Installer's Debian package

Feature #8563: Adjust Linux installation doc wrt. Tails Installer in Debian

Feature #8805: Have Tails Installer in Jessie backports

Feature #8806: Research calendar for inclusion in Ubuntu

Feature #8866: Rework the wording of Tails Installer

Feature #8867: Point to website to download ISO image

Feature #8553: Adapt Tails Installer packaging to its rename

Feature #9672: Rework wording of Tails installer in Wheezy

Feature #8554: Repack a DFSG-free Tails Installer tarball

Feature #9673: Rework wording of Tails installer in Jessie

Bug #10236: Repair l10n of the installer after the port to Gtk3

Feature #8555: Adapt packaging process and release doc for Tails Installer DFSG-free tarball

Feature #9674: Correct documentation of Tails installer with new wording

Make Tails Installer work fine outside of Tails

Added by intrigeri almost 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Installation
Target version:
Start date:
05/12/2015
Due date:
% Done:

81%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Installer

Description

  • add support for "install from ISO"
  • make sure "upgrade from ISO" works outside of Tails
  • create a tails-installer-launcher that only proposes these two options
  • refactor things as needed
  • also ship an amd64 syslinux binary in the ISO, otherwise Tails Installer will only work on 32-bit systems

Subtasks


Related issues

Duplicated by Tails - Feature #8865: Implement "Install from ISO" in Tails Installer Duplicate 02/04/2015
Blocked by Tails - Feature #7046: Design scenario and features for a Tails Installer package in Debian Resolved
Blocks Tails - Feature #8557: Have Tails Installer uploaded and accepted into Debian Resolved 01/06/2015
Blocked by Tails - Bug #8455: Have gdisk fixed in Jessie Resolved 12/18/2014

History

#1 Updated by intrigeri almost 5 years ago

  • Blocked by Feature #7046: Design scenario and features for a Tails Installer package in Debian added

#2 Updated by intrigeri almost 5 years ago

  • Blocks Feature #8557: Have Tails Installer uploaded and accepted into Debian added

#4 Updated by u over 4 years ago

  • Blocked by Bug #8274: liveusb-creator's gdisk scripts returns error in Jessie added

#5 Updated by u over 4 years ago

  • Target version changed from Hardening_M1 to Tails_1.4

#6 Updated by intrigeri over 4 years ago

  • Blocked by deleted (Bug #8274: liveusb-creator's gdisk scripts returns error in Jessie)

#7 Updated by intrigeri over 4 years ago

  • Blocked by Bug #8455: Have gdisk fixed in Jessie added

#8 Updated by intrigeri over 4 years ago

  • Description updated (diff)

#9 Updated by u over 4 years ago

sidenote: I've built a test package and tested it on a Debian Jessie. When I click "install" though, the updating process seems to be called and I can't install from ISO.

#10 Updated by intrigeri over 4 years ago

sidenote: I've built a test package and tested it on a Debian Jessie.

Woohoo, here we go!

When I click "install" though, the updating process seems to be called and I can't install from ISO.

I would suggest to tackle this part of this ticket first, then:

  • add support for "install from ISO"

I would start with running liveusb-creator by hand. I would start from the command-line the launcher uses for "Upgrade from ISO", and add to it whatever option "Clone and Install" uses in order to enable partitioning of the target device. It might be that it's enough to get "Install from ISO" working, but most likely some code changes will be needed.

By the way, now that you're on it, please file sub-tickets for each deliverable that's listed in the ticket's description.

#11 Updated by u over 4 years ago

Notes:

Design documentation: https://tails.boum.org/contribute/design/installation/

using liveusb-creator -n -x -v we miss the path to syslinux from the ISO:

/tmp/tmpDcHx2_/syslinux  -d syslinux /dev/sdb1
/bin/sh: 1: /tmp/tmpDcHx2_/syslinux: not found

we need to make sure the syslinux installed on the MBR matches exactly the syslinux modules extracted from the ISO.
you might be hit by the lack of a 64-bit syslinux binary in the ISO, though.

#12 Updated by u over 4 years ago

  • Target version changed from Tails_1.4 to Tails_1.4.1

#13 Updated by u over 4 years ago

we need to make sure the syslinux installed on the MBR matches exactly the syslinux modules extracted from the ISO.
you might be hit by the lack of a 64-bit syslinux binary in the ISO, though.

That actually concerns only the 64bit version for now, which is handled by #9381

#14 Updated by intrigeri over 4 years ago

  • Blocked by Bug #9612: Race condition after creating partition in Tails Installer on Jessie added

#15 Updated by intrigeri over 4 years ago

  • Blocked by deleted (Bug #9612: Race condition after creating partition in Tails Installer on Jessie)

#16 Updated by intrigeri about 4 years ago

  • Status changed from Confirmed to In Progress

#17 Updated by u about 4 years ago

  • Target version changed from Tails_1.5 to Tails_1.6

#18 Updated by intrigeri about 4 years ago

I see that the launcher has a link to "documentation", that's broken outside of Tails. It would be good to grep for other similar issues.

#19 Updated by u about 4 years ago

intrigeri wrote:

I see that the launcher has a link to "documentation", that's broken outside of Tails. It would be good to grep for other similar issues.

nice find.
i corrected this in [feature/jessie 930168e].

#20 Updated by u about 4 years ago

did not find similar issues, but po files need to be uodated with the new strings.

#21 Updated by u about 4 years ago

  • Target version changed from Tails_1.6 to Tails_1.7

#22 Updated by intrigeri about 4 years ago

I remember we had that encoding bug, that occured only when run in some non-English locales, when some external process failed and output non-ascii chars in its error message. Is that bug tracked somewhere? It's probably a blocker for uploading to sid, but maybe not for uploading to experimental first.

Anything else remaining to do here, that would be a blocker for the initial upload to sid?

#23 Updated by u about 4 years ago

intrigeri wrote:

I remember we had that encoding bug, that occured only when run in some non-English locales, when some external process failed and output non-ascii chars in its error message. Is that bug tracked somewhere? It's probably a blocker for uploading to sid, but maybe not for uploading to experimental first.

opened a new ticket here: #10327

Anything else remaining to do here, that would be a blocker for the initial upload to sid?

i think everything else has been resolved. yay!

#24 Updated by u about 4 years ago

  • Assignee changed from u to intrigeri
  • QA Check set to Ready for QA

#25 Updated by intrigeri about 4 years ago

  • Blocked by Bug #10327: Verify and correct eventual encoding bugs in Tails installer added

#26 Updated by intrigeri about 4 years ago

  • Blocked by deleted (Bug #10327: Verify and correct eventual encoding bugs in Tails installer)

#27 Updated by intrigeri about 4 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

Indeed, I don't see any issue left that's specific to "outside of Tails". Closing. Congrats!

#28 Updated by sajolida about 4 years ago

  • Duplicated by Feature #8865: Implement "Install from ISO" in Tails Installer added

Also available in: Atom PDF