Project

General

Profile

Feature #8552

Feature #7544: Have a multiplatform Installer

Feature #8550: Make Tails Installer work on Windows

Feature #8558: Study feasibility of porting Tails Installer to Windows

Rename liveusb-creator to Tails Installer

Added by intrigeri almost 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Installation
Target version:
Start date:
10/17/2015
Due date:
% Done:

100%

Feature Branch:
feature/8552+rename-tails-installer
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Installer

Description

Software, classes and all.


Subtasks

Feature #10384: Tails Installer: Merge master into feature/jessieResolved


Related issues

Blocks Tails - Feature #8553: Adapt Tails Installer packaging to its rename Resolved 01/06/2015

History

#1 Updated by intrigeri almost 5 years ago

  • Blocks Feature #8553: Adapt Tails Installer packaging to its rename added

#3 Updated by u over 4 years ago

  • Target version changed from Hardening_M1 to Tails_1.4

#4 Updated by u over 4 years ago

  • Target version changed from Tails_1.4 to Tails_1.4.1

#5 Updated by u over 4 years ago

  • Target version changed from Tails_1.4.1 to Tails_1.5

#6 Updated by u over 4 years ago

  • Target version changed from Tails_1.5 to Tails_1.6

#7 Updated by u about 4 years ago

  • Target version changed from Tails_1.6 to Tails_1.7

#8 Updated by u about 4 years ago

  • Status changed from Confirmed to In Progress
  • Feature Branch set to feature/8552+rename-tails-installer

#9 Updated by u about 4 years ago

  • Assignee changed from u to intrigeri
  • QA Check set to Ready for QA

#10 Updated by u about 4 years ago

  • Assignee changed from intrigeri to u
  • QA Check changed from Ready for QA to Dev Needed

depends on #10384 (message handling) which i need to fix first in both branches.

#11 Updated by u about 4 years ago

  • Assignee changed from u to intrigeri
  • QA Check changed from Dev Needed to Ready for QA

ok, now it's ready for review. I did some basic testing but i've not yet remerged all this into the debian/sid branch nor built a package.

I've manually added intrigeri's commit from master which deletes the obsolete md5sum verification.

#12 Updated by intrigeri about 4 years ago

  • Status changed from In Progress to Resolved

ok, now it's ready for review.

At first glance it looks good. I'll test once #8553 is done too.

I've pushed commit caecc81 on top.

Note that I've rebased your branch on top of feature/jessie to clean the history a bit first: you have apparently rewritten some commits in that branch, that you have submitted from merging elsewhere, and that have been merged already. I hope that you haven't based other work on this buggy history already (and if you have I'll help you deal with it since I took the responsibility to rewrite history myself before merging).

I'm curious: why were tails-liveusb-header.* not renamed?

i've not yet remerged all this into the debian/sid branch nor built a package.

Indeed, that's for #8553, which is your next step I think (and the last blocker, with #10327, before we can upload to Debian).

I've manually added intrigeri's commit from master which deletes the obsolete md5sum verification.

This one is in feature/jessie already (as 3512021bff593da108968a05c5f853ff7fe5b98d) because you included it in another branch so my history rewrite got rid of it.

#13 Updated by intrigeri about 4 years ago

  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

Also available in: Atom PDF