Project

General

Profile

Bug #8505

Jessie: there is an unclear and useless Sundry category in Applications menu

Added by alant over 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
12/31/2014
Due date:
10/15/2015
% Done:

100%

QA Check:
Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

There is an unclear"Sundry" category in Applications menu, containing only system-config-printer entry. Given that similar functionnality is provided by gnome-control-center I propose that we remove system-config-printer as proposed in #8443. I tested it actually removes the category in a running Tails/Jessie and doesn-t prevent from adding a printer througn GNOME Settings.


Related issues

Related to Tails - Bug #8443: Adding a new printer requires administration password Resolved 12/15/2014
Related to Tails - Bug #8069: Weird "Sundry" submenus in Applications on Jessie Resolved 10/11/2014
Related to Tails - Bug #10965: Some printers cannot be added via GNOME Resolved 01/18/2016

Associated revisions

Revision 84c0feb8 (diff)
Added by intrigeri over 3 years ago

Stop installing system-config-printer.

It's been there since the first commit, mostly because back in the
years, it was the only decent CUPS GUI available; nowadays, GNOME's one
is good enough; we explicitly document that one should use the latter
anyway, and as shown by #8443, even us are sometimes confused by (or
reporting confusing information about) the fact that we ship 2 GUIs for
the same task.

Besides, on Jessie system-config-printer adds "an unclear and useless
Sundry category in Applications menu".

Note that typing in the sudoer password is still required to manage
printers, but that's not a Jessie regression and it's tracked by

Closes: #8505

History

#1 Updated by alant over 4 years ago

  • Related to Bug #8443: Adding a new printer requires administration password added

#2 Updated by sajolida over 4 years ago

  • Duplicates Bug #8069: Weird "Sundry" submenus in Applications on Jessie added

#3 Updated by sajolida over 4 years ago

  • Status changed from Confirmed to Duplicate

#4 Updated by sajolida over 4 years ago

This is a duplicate from #8069. Apparently, this menu appears when some applications are included and then disappears...

#5 Updated by alant over 4 years ago

  • Status changed from Duplicate to Confirmed

This is a duplicate from #8069.

#8069 is a resolved Research ticket, so I fail to see how it can be a duplicate of an actual bug, which we know how to solve.

Apparently, this menu appears when some applications are included and then disappears...

This category contains "things that either aren't really apps or are scheduled for removal but that are hard to remove at the moment for various reasons". See https://git.gnome.org/browse/gnome-menus/commit/?id=36d5d699d7d4193a1b3d84777566466326f78b19 and https://bugzilla.gnome.org/show_bug.cgi?id=694131 for more info about this caregory. So removing the only remaining outdated app we ship (system-config-printer) solves the issue.

#6 Updated by alant over 4 years ago

  • Duplicates deleted (Bug #8069: Weird "Sundry" submenus in Applications on Jessie)

#7 Updated by alant over 4 years ago

  • Related to Bug #8069: Weird "Sundry" submenus in Applications on Jessie added

#8 Updated by intrigeri about 4 years ago

  • Assignee set to alant
  • QA Check set to Info Needed

alant wrote:

I propose that we remove system-config-printer as proposed in #8443. I tested it actually removes the category in a running Tails/Jessie and doesn-t prevent from adding a printer througn GNOME Settings.

Do you remember if you were asked the admin password for doing so via GNOME settings? In other words, was #8443 fixed between Wheezy and Jessie? If it wasn't, then I'd like to raise this problem on the Debian side.

(On my own sid system, I could find nothing in /usr/share/polkit-1/actions/ that would seem to allow adding printers without an admin password, except cups-pk-helper that is only there because it's recommended by system-config-printer -- hence my doubt and question. :)

#9 Updated by alant about 4 years ago

  • Assignee changed from alant to intrigeri

Do you remember if you were asked the admin password for doing so via GNOME settings? In other words, was #8443 fixed between Wheezy and Jessie? If it wasn't, then I'd like to raise this problem on the Debian side.

I'm not sure I understand correctly what do you mean by "doing so". To add a printer through GNOME settings under Tails/Jessie, I need to click une "Unlock" button, which make a password entry window appear. The very same UX applies to system-config-printer.

#10 Updated by intrigeri about 4 years ago

  • Assignee changed from intrigeri to alant

alant wrote:

To add a printer through GNOME settings under Tails/Jessie, I need to click une "Unlock" button, which make a password entry window appear. The very same UX applies to system-config-printer.

Thanks. Is it also the case if you deinstall cups-pk-helper? This question applies to both printer configuration methods.

#11 Updated by intrigeri almost 4 years ago

  • Due date set to 10/15/2015

#13 Updated by intrigeri almost 4 years ago

  • Subject changed from There is an unclear and useless Sundry category in Applications menu to Jessie: there is an unclear and useless Sundry category in Applications menu
  • Target version changed from Tails_2.0 to Tails_1.6

#17 Updated by alant over 3 years ago

  • Assignee deleted (alant)
  • QA Check deleted (Info Needed)

intrigeri wrote:

Thanks. Is it also the case if you deinstall cups-pk-helper? This question applies to both printer configuration methods.

Without cups-pk-helper:

  • there is no way to add a printer in Sytem Settings anymore
  • system-config-printer segfaults

#18 Updated by intrigeri over 3 years ago

  • Assignee set to intrigeri

#19 Updated by intrigeri over 3 years ago

alant wrote:

Without cups-pk-helper:

  • there is no way to add a printer in Sytem Settings anymore

OK. Seems to be confirmed by:

So indeed, seems that we should remove system-config-printer and as long as we keep cups-pk-helper it should work with a sudoer password. Having it work without any authentication is #8443, and given the above the suggested changes on feature/jessie should not make this any harder.

#20 Updated by intrigeri over 3 years ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

#21 Updated by intrigeri almost 3 years ago

  • Related to Bug #10965: Some printers cannot be added via GNOME added

Also available in: Atom PDF