Project

General

Profile

Bug #8470

Clean up APT preferences post-migration to Tor Browser

Added by intrigeri about 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
12/21/2014
Due date:
% Done:

100%

Feature Branch:
bugfix/8470-clean-up-apt-pinning
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Browser

Description

We still have APT pinning for e.g. xul-ext-https-everywhere and xul-ext-noscript, that we don't ship anymore from Debian packages (but instead using the copy from the Tor Browser).

Associated revisions

Revision b34ac27d (diff)
Added by Tails developers about 5 years ago

Drop APT pinning for HTTPS Everywhere and NoScript (will-fix: #8470).

We now take these extensions from the Tor Browser tarball.

History

#1 Updated by Tails about 5 years ago

  • Status changed from Confirmed to In Progress

Applied in changeset commit:34749bcf975a1aaaf96788713f7c98fc72fc80b1.

#2 Updated by intrigeri about 5 years ago

  • % Done changed from 0 to 10
  • Feature Branch set to bugfix/8470-clean-up-apt-pinning

#3 Updated by intrigeri about 5 years ago

  • Assignee deleted (intrigeri)
  • % Done changed from 10 to 50
  • QA Check set to Ready for QA

#4 Updated by alant about 5 years ago

  • Assignee set to intrigeri
  • QA Check changed from Ready for QA to Dev Needed

I reviewed the branch and I'm happy with the code the (empty) apt suite as well as with the result. I'm wondering though:

  • should we still advertize these two extensions in doc/about/features and in doc/anonymous_internet/Tor_Browser? They are actually just part of the torbrowser.
  • why do we still install xul-ext-torbutton from debian repositories?

#5 Updated by BitingBird about 5 years ago

Maybe we can remove the details from "features", but we definitly want to leave an explanation somewhere about noscript, because users ask a lot of questions about it, and the page "Tor Browser" seems a good place to keep this information available.

#6 Updated by intrigeri about 5 years ago

I reviewed the branch and I'm happy with the code the (empty) apt suite as well as with the result. I'm wondering though:

  • should we still advertize these two extensions in doc/about/features and in doc/anonymous_internet/Tor_Browser? They are actually just part of the torbrowser.

No idea. Please file a dedicated ticket about that, since it's entirely orthogonal to this one.

  • why do we still install xul-ext-torbutton from debian repositories?

Because we patch it.

=> please merge?

#7 Updated by intrigeri about 5 years ago

  • Assignee changed from intrigeri to alant
  • QA Check changed from Dev Needed to Ready for QA

#8 Updated by intrigeri about 5 years ago

  • % Done changed from 50 to 80

#9 Updated by alant about 5 years ago

should we still advertize these two extensions in doc/about/features and in doc/anonymous_internet/Tor_Browser? They are actually just part of the torbrowser.

No idea. Please file a dedicated ticket about that, since it's entirely orthogonal to this one.

I don't care that much, just wondering. Please file a ticket if you find it relevant.

why do we still install xul-ext-torbutton from debian repositories?

Because we patch it.

OK I'm convinced.

#10 Updated by alant about 5 years ago

  • Status changed from In Progress to 11
  • Assignee deleted (alant)
  • % Done changed from 80 to 100
  • QA Check changed from Ready for QA to Pass

#11 Updated by intrigeri about 5 years ago

why do we still install xul-ext-torbutton from debian repositories?

Because we patch it.

OK I'm convinced.

(actually, just checked: that's in the design doc already :)

#12 Updated by BitingBird about 5 years ago

  • Category deleted (176)
  • Affected tool set to Browser

#13 Updated by BitingBird almost 5 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF