Project

General

Profile

Feature #8401

Feature #6338: User-friendly keysigning that verifies that key belongs to the recipient

Improve monkeysign integration in Tails

Added by intrigeri over 4 years ago. Updated about 1 month ago.

Status:
Rejected
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
12/06/2014
Due date:
% Done:

0%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Yes
Affected tool:

Description

Our initial integration of monkeysign is lacking in many ways (see parent ticket). We've evaluated GNOME keysign but it's not an alternative to replace monkeysign with it. Thus we should put more work into improving monkeysign's integration into Tails.

Before working on this, see #11240 that has updates about the future (or lack thereof) of monkeysign.


Related issues

Related to Tails - Feature #11240: Document monkeysign Rejected 03/15/2016
Related to Tails - Feature #14581: Install caff (signing-party) by default Rejected 09/01/2017
Blocked by Tails - Feature #8400: Test & evaluate GNOME Keysign Resolved 12/06/2014

History

#1 Updated by intrigeri over 4 years ago

#2 Updated by u about 2 years ago

  • Description updated (diff)

#3 Updated by u almost 2 years ago

As gnome-keysign covers only a very specific usecase, it cannot replace monkeysign. So we can only improve monkeysign's integration in Tails.

#4 Updated by u almost 2 years ago

  • Subject changed from Decide between GNOME Keysign or improving monkeysign integration to Improve monkeysign integration in Tails

#5 Updated by u almost 2 years ago

  • Type of work changed from Discuss to Wait

I'm not sure if this is still an up-to-date request at all.

#6 Updated by u over 1 year ago

  • Description updated (diff)
  • Type of work changed from Wait to Research
  • Starter set to Yes

In order to make this happen, we need to research how well monkeysign works in Tails or if there are any missing features or usecases. And collect the output on this ticket.

#7 Updated by sajolida over 1 year ago

My user story:

I've been using monkeysign in Tails successfully for all my key signing.

Whenever I sign a key, I get back to #11240 to copy the lenghtly command line in there. I have no feedback on the security of monkeysign when connecting to my server but I trust the monkeysign developer to not be silly and I think I checked that it does SSL as some point in the past.

I use monkeysign for that because I failed to used caff in the past and monkeysign worked for me. I don't use monkeysign for anything else (it does key verification using some QR code, right?) because I'm really used to extensive fingerprint verification, either on paper, business card, or screen and don't need anything else.

#8 Updated by u 11 months ago

  • Description updated (diff)

#9 Updated by u 11 months ago

#10 Updated by u 11 months ago

  • Related to Feature #14581: Install caff (signing-party) by default added

#11 Updated by intrigeri 5 months ago

  • Description updated (diff)
  • Priority changed from Normal to Low

#12 Updated by sajolida about 1 month ago

  • Status changed from Confirmed to Rejected

We removed monkeysign in 3.14.

Also available in: Atom PDF