Project

General

Profile

Bug #8319

OpenPGP Applet: Add a confirmation dialog on exit

Added by nodens over 4 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
11/26/2014
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Yes
Affected tool:
OpenPGP Applet

Description

Tails OpenPGP Applet should ask confirmation before exiting, especially since there is no shortcut to launch it.


Related issues

Related to Tails - Bug #7450: Tails OpenPGP Applet is too easy to exit Resolved 06/22/2014
Blocked by Tails - Feature #10190: Install OpenPGP Applet from Debian Resolved 03/16/2016

History

#1 Updated by nodens over 4 years ago

  • Related to Feature #6507: Package our OpenPGP applet for Debian and maintain it there added

#2 Updated by nodens over 4 years ago

  • Status changed from New to Confirmed

#3 Updated by intrigeri over 4 years ago

  • Related to Bug #7450: Tails OpenPGP Applet is too easy to exit added

#4 Updated by nodens over 4 years ago

  • Assignee changed from nodens to intrigeri
  • % Done changed from 0 to 70
  • QA Check set to Ready for QA
  • Starter set to Yes

The code is available on my openpgp-applet repository, in the branch bugfix/8319-Add_a_confirmation_on_exit.

intrigeri, I'm assigning it to you for review since we agreed this is only meant to be available in the packaged version (#6507), and not in the version currently in Tails.

#5 Updated by intrigeri over 4 years ago

  • Subject changed from Tails OpenPGP Applet : Add a confirmation dialog on exit to OpenPGP Applet: Add a confirmation dialog on exit
  • Assignee changed from intrigeri to nodens
  • % Done changed from 70 to 80
  • QA Check changed from Ready for QA to Dev Needed

nodens wrote:

The code is available on my openpgp-applet repository, in the branch bugfix/8319-Add_a_confirmation_on_exit.

Looks good, but IMO app_exit should take $main_window as an argument, instead of relying on the global variable.

#6 Updated by BitingBird over 4 years ago

  • Status changed from Confirmed to In Progress

#7 Updated by nodens over 4 years ago

  • Assignee changed from nodens to intrigeri
  • QA Check changed from Dev Needed to Ready for QA

You're right.

Now app_exit take the parent window for the dialog as argument.

If that's OK for you, I'll merge it with master and change the status to "fix commited".

#8 Updated by intrigeri over 4 years ago

  • Assignee changed from intrigeri to nodens
  • % Done changed from 80 to 90
  • QA Check changed from Ready for QA to Pass

Assuming it was tested and works fine: ACK :)

#9 Updated by nodens over 4 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (nodens)
  • % Done changed from 90 to 100

It was, and it does :)

#10 Updated by BitingBird over 4 years ago

  • Affected tool set to OpenPGP Applet

#11 Updated by anonym about 4 years ago

Can we mark this ticket as resolved? I don't get it.

#12 Updated by intrigeri about 4 years ago

Can we mark this ticket as resolved?

I think it was only resolved in the wanna-be-autonomous OpenPGP Applet. Unless it was merged into our own Git, but then the ticket and Git history will let you know.

#13 Updated by nodens almost 4 years ago

  • Related to deleted (Feature #6507: Package our OpenPGP applet for Debian and maintain it there)

#14 Updated by BitingBird about 3 years ago

#15 Updated by nodens over 2 years ago

  • Status changed from Fix committed to Resolved

fixed in tails 2.6

Also available in: Atom PDF