Project

General

Profile

Bug #8277

CapsLock keyboard light gets inverted if on during Greeter

Added by emmapeel about 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Low
Assignee:
-
Category:
Hardware support
Target version:
Start date:
11/19/2014
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Greeter

Description

Reported by user:

If you use the CapsLock in the Tails Greeter, the light of the keyboard gets switched (on when is off, off when is on) during the whole session.

History

#1 Updated by sajolida about 5 years ago

  • Status changed from New to Confirmed
  • Assignee set to emmapeel
  • QA Check set to Info Needed

I'm not sure to understand your description of the problem. I managed to reproduce only part of what you are describing:

  • If I start Tails and swich on capslock in Greeter.
  • Then the capslock light get switched off when I enter the session.
  • I can still switch capslock on and off using the capslock key but the light is desynchronized with the capslock feature: the light if off when capslock is on, and the light is on when capslock is off.

If this is the same problem as yours then please try to clarify the description of the ticket.

#2 Updated by emmapeel about 5 years ago

  • Subject changed from CapsLock gets switched if on during Greeter to CapsLock gets inverted if on during Greeter

#3 Updated by emmapeel about 5 years ago

  • Subject changed from CapsLock gets inverted if on during Greeter to CapsLock keyboard light gets inverted if on during Greeter

Yes, it is the same problem. I have changed the title now, does it look more clear? You can still change it, is jsut that the light is inverted

#4 Updated by sajolida about 5 years ago

Crystal clear, thanks!

#5 Updated by intrigeri about 5 years ago

  • Assignee deleted (emmapeel)
  • QA Check deleted (Info Needed)
  • Type of work changed from Test to Code

#6 Updated by BitingBird about 5 years ago

  • Category changed from 165 to Hardware support
  • Affected tool set to Greeter

#7 Updated by intrigeri about 4 years ago

  • Status changed from Confirmed to Resolved
  • Target version set to Tails_2.0
  • % Done changed from 0 to 100

I can't reproduce this on current feature/jessie, so apparently this was fixed in Debian along the way :)

#8 Updated by Pineapplepeopleeater about 4 years ago

I can reproduce this problem in 1.7 and now 1.8 just out.

Reproduced on
2x Intel based Laptops
1x Macbook
1x whitebox (as in self built PC/desktop)

It actually caught me out as i set a password in capitals to test something else and then ran into the above.

#9 Updated by intrigeri over 2 years ago

  • Related to Bug #13204: In the greeter, Caps lock warning icon should stay visible as long as Caps Lock is on added

#10 Updated by intrigeri over 2 years ago

  • Related to deleted (Bug #13204: In the greeter, Caps lock warning icon should stay visible as long as Caps Lock is on)

Also available in: Atom PDF