Project

General

Profile

Bug #8269

Alert users that file transfers in Pidgin are not encrypted

Added by emmapeel about 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
11/17/2014
Due date:
% Done:

50%

Feature Branch:
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:
Instant Messaging

Description

Pidgin provides encryption for text, but does not encrypt file transfers.

I have opened a ticket at pidgin-otr bug tracker (https://bugs.otr.im/issues/66) but we should document it somewhere on our website.

0001-Pidgin-alert-for-file-transfers.patch View (5.79 KB) emmapeel, 11/19/2014 03:39 PM

History

#1 Updated by sajolida about 5 years ago

  • Status changed from New to Confirmed
  • Assignee set to emmapeel
  • Priority changed from Normal to Elevated

Great. This should definitely go as another warning on https://tails.boum.org/doc/anonymous_internet/pidgin/.

I think that this is important enough to be right below the warning about "OTR is deactivated by default".

Then also maybe to put more emphasis on this one rather than on the warning about /me commands we could change the /me command to be a class="bug". Because I find it relatively less important.

Emma Peel: do you want to write a draft for that one? Otherwise reassign it to me.

This is quite important and easy so let's mark this as "elevated" and for 1.3.

#2 Updated by emmapeel about 5 years ago

Here a patch. I'm somewhat wary of the massive amount of alerts on the page, though...

#3 Updated by intrigeri about 5 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from emmapeel to sajolida
  • Target version set to Tails_1.3
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA

emmapeel, I'm doing what you should have done when submitting the patch. All this is documented in our merge policy, so you can look it up there next time :)

(Also, I suspect that sajolida would prefer a Git branch, but I'll let him complain if he needs to.)

#4 Updated by sajolida about 5 years ago

  • Status changed from In Progress to Duplicate
  • Assignee deleted (sajolida)
  • QA Check deleted (Ready for QA)

#5 Updated by sajolida about 5 years ago

  • Status changed from Duplicate to Resolved

Also available in: Atom PDF