Project

General

Profile

Feature #8253

Consider shipping a tool to easily edit a batch of pictures

Added by abcfr about 5 years ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
11/12/2014
Due date:
% Done:

0%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Yes
Affected tool:

Description

We are looking for a GUI tool which

- is easy to use (good UX/integration)
- actively maintained upstream (try to find out when the last version was released upstream)
- exists as an official Debian package on https://tracker.debian.org and is actively maintained (The tracker page shows the last version's upload date)
- doesn't pull in too many dependencies we don't already ship (This can be found out looking at the Debian tracker page)
- provides the possibility to quickly resize a batch of pictures (not only one at a time)

If you are interested in working on this ticket, please assign it to yourself, and maybe get in touch with us (https://tails.boum.org/about/contact/index.en.html#index3h2) over the tails-dev mailinglist.

nautilus-image-converter-resize.png View (26.7 KB) sajolida, 02/11/2015 02:58 PM

nautilus-image-converter-rotate.png View (24.9 KB) sajolida, 02/11/2015 02:58 PM

nautilus-image-manipulator-custom.png View (36.8 KB) sajolida, 02/11/2015 02:58 PM

nautilus-image-manipulator-main..png View (12.9 KB) sajolida, 02/11/2015 02:58 PM


Related issues

Related to Tails - Feature #15543: Give a list of examples of nice software to install each time Confirmed 04/17/2018

History

#1 Updated by intrigeri about 5 years ago

  • Type of work changed from Debian to Discuss
  • Starter changed from Yes to No

There are many tools in Debian that implement such functionality, and everyone will have their preferred one. Given that, and the fact that this usecase very much borderline wrt. the Tails design goals, I think I'd rather not see us choose one of these tools and ship it, and instead leave it to users to pick the one they prefer and install it themselves.

#2 Updated by abcfr about 5 years ago

IMHO, imagemagick is the reference cli tool in linux to edit pictures. Activists do have the need to edit multiple pictures i.e. before publishing them on the web, and there is currently no tool to do that shipped with TAILS :-/
As I'm not involved in the TAILS devloppement, I won't argue any longuer this topic and respect your choice :)

#3 Updated by sajolida about 5 years ago

Note that all the dependencies of imagemagick (including libmagickcore5)
are already included in Tails as required by inkscape.

Here is the output of dpkg-query -Wf '${Installed-Size}\t${Package}\n' |
grep magick after installing imagemagick:

367 imagemagick
320 imagemagick-common
555 libmagick++5
5899 libmagickcore5
1267 libmagickwand5

In other words we already have 95% of imagemagick in Tails.

intrigeri: just out of curiosity, which other many tools were your
referring to? I mostly knew and used imagemagick myself and thought it
was the reference for command-line image processing.

#4 Updated by intrigeri about 5 years ago

intrigeri: just out of curiosity, which other many tools were your referring to?

I've been recommended to use phatch, that has both a CLI and a GUI. There's also converseen (in Jessie).

#5 Updated by matsa about 5 years ago

I recommend nautilus-image-converter, which adds entries to resize and rotate pictures in nautilus' right-clic menu.

Note that after installation, you have to restart nautilus, with the command line nautilus -q. For that reason, and because this is indeed a common usecase, I propose to include it in Tails by default. The size of nautilus-image-converter is 678 ko once installed.

#6 Updated by sajolida about 5 years ago

  • Type of work changed from Discuss to Research

Now we need to research the cost and benefits of those different solutions and decide something to the light of this.

#7 Updated by intrigeri about 5 years ago

Now we need to research the cost and benefits of those different solutions and decide something to the light of this.

The discussion that happened on this ticket actually seems to confirm what I wrote initially in comment 1, so I'm still of the opinion that we should install none of those, and instead let each user install the one they want. Now, that's not a veto, but IMO that's low priority at best.

#8 Updated by sajolida about 5 years ago

  • Priority changed from Normal to Low

#9 Updated by intrigeri about 5 years ago

  • Type of work changed from Research to Discuss

#10 Updated by bertagaz almost 5 years ago

  • Subject changed from a tool to quickly edit (resize...) pictures to Ship a tool to quickly edit (resize...) pictures
  • Status changed from New to Confirmed
  • % Done changed from 0 to 10
  • Type of work changed from Discuss to Research
  • Starter changed from No to Yes

During the February 2015 meeting, we decided this could fit in Tails use cases, so we need a GUI tool for that.

There are a bunch of nautilus plugins that can do that: nautilus-image-converter, nautilus-image-manipulator. So next step is to test them and then decide to pick one or none.

Requirements: sanely developed and maintained upstream.

Flagging easy, as it's a research ticket for now.

#11 Updated by sajolida almost 5 years ago

It tried both.

  • I already had all the dependencies for nautilus-image-converter, and it asked for 302 kB of additional disk space. It creates two new entries in the contextual menu of Nautilus: Resize Images... and Rotate Images...
  • Installing nautilus-image-manipulator installed 5 extra packages (gir1.2-nautilus-3.0 libboost-python1.49.0 python-nautilus python-poster python-pyexiv2) and 2568 kB of additional disk space. It creates a new entry in the contextual menu of Nautilus: Resize Image which proposes amongst others, an window to resize. But you have to go through a first dialog which proposes to upload the image to an online service.

So I would go for nautilus-image-converter which is smaller and more appropriate even if the custom options of nautilus-image-manipulator look nicer and propose a setting for quality.

See screenshots in attachment.

#13 Updated by intrigeri almost 5 years ago

  • Status changed from Confirmed to In Progress

#14 Updated by intrigeri almost 5 years ago

Thanks for this report!

Here's some additional info:

  • popcon: -converter has 2.5 times more users than -manipulator in Debian. No big surprise, it's been around for much longer, and was part of Squeeze while -manipulator was only introduced in Wheezy.
  • upstream:
    • -manipulator's last upstream release (1.3) was put out in April, 2013. The only change since then has been the conversion from bzr to Git, that happened late in 2014. It seems to be a one-man show.
    • -converter lives on gnome.org. Its last upstream release dates back to 2008. There has been exactly one commit since 2011.
  • Debian:
    • -manipulator is maintained in Debian by its upstream author. Apparently the package quality and maintenance are decent.
    • -converter is maintained in Debian by an individual. Last upload (a Git snapshot) is from late 2011, which is not a surprise since there's been little progress upstream since then. Still, it's a little bit worrying that the only upstream bugfix since then hasn't been uploaded to Debian, and that the packaging seems to be ancient and far from following today's best practices (e.g. no relro hardening, too bad for a tool that's meant to be used on untrusted data). Worse, none of the open Debian bug reports have been answered by the maintainer or forwarded upstream since 2011, some of them having a patch attached.

So, my conclusion is that -converter is even more worrying from a maintainability point-of-view than -manipulator, which is itself not exactly confidence-inspiring in this respect. So perhaps we should pick either one on other grounds (e.g. thanks to sajolida's testing), but we should feel free to remove it later if it becomes a maintenance burden: IMO that's not an important enough use case to e.g. become the de facto upstream or Debian maintainers of such tools.

#15 Updated by u over 2 years ago

The ticket description here does not apply anymore: imagemagick is in Tails 3.0. So there is a tool to quickly resize images, on the command line at least.

#16 Updated by u over 2 years ago

Now, there is no out of the box GUI tool to do this, except for blown up Gimp.

Tasks to move this ticket forward: choose a tool. The debian package of nautilus-image-manioulator has seen no update in >3 years. nautilus-image-converter has though. It seems to be maintained by the Debian QA group: https://tracker.debian.org/pkg/nautilus-image-converter nowadays. This inverts what intrigeri has researched before.

We should try to decide at the next monthly meeting if we really want to include this tool IMO.

#17 Updated by u over 2 years ago

  • Type of work changed from Research to Discuss

#18 Updated by intrigeri over 2 years ago

  • Assignee set to u
  • Type of work changed from Discuss to Contributors documentation

During https://tails.boum.org/contribute/meetings/201707/ Ulrike volunteered to turn this ticket into a low priority, "Easy", Type of work = Research one.

Requirements:

  • GUI
  • good UX/integration
  • actively maintained
  • doesn't pull in too many dependencies we don't already ship

#19 Updated by u over 2 years ago

  • Subject changed from Ship a tool to quickly edit (resize...) pictures to Consider shipping a tool to easily edit a batch pictures
  • Description updated (diff)
  • Status changed from In Progress to Confirmed
  • Assignee deleted (u)
  • % Done changed from 10 to 0
  • Type of work changed from Contributors documentation to Research

#20 Updated by u over 2 years ago

  • Subject changed from Consider shipping a tool to easily edit a batch pictures to Consider shipping a tool to easily edit a batch of pictures

#21 Updated by u over 1 year ago

  • Status changed from Confirmed to Rejected

I'm in favor of rejecting this ticket because this will be solved by ASP. However, we might want to give an example for such a tool. Reopen if you do not agree.

#22 Updated by u over 1 year ago

  • Related to Feature #15543: Give a list of examples of nice software to install each time added

Also available in: Atom PDF