Project

General

Profile

Feature #8194

Feature #5379: Remove Polipo or replace it with Privoxy

Have APT directly use the Tor SOCKS proxy

Added by intrigeri about 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
11/02/2014
Due date:
% Done:

50%

Feature Branch:
feature/8194-APT-socks
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

See parent ticket for the rationale and early work on this.


Related issues

Related to Tails - Feature #8198: Replace tor+http shim with apt-transport-tor Resolved 11/03/2014
Blocks Tails - Feature #5307: Fix the Wheezy build in a nicer way Resolved

Associated revisions

Revision e0e45f81 (diff)
Added by Tails developers about 5 years ago

Have APT directly use the Tor SOCKS proxy (Closes: #8194).

At the end of the chroot_local-hooks stage, we replace the hook that used to
tell APT to use the Polipo HTTP proxy with another one that does (a more
elaborate version) s,http://,tor+http://, in APT sources.

Then, APT will use the "tor+http" method, that we install in
/usr/lib/apt/methods, and that is a simple torsocks wrapper for the
"http" method.

History

#1 Updated by intrigeri about 5 years ago

Failed to backport apt-transport-tor for Wheezy, asked the maintainer.

Someone should retry the shim idea, then, as documented on the parent ticket. I think that our build system now supports some APT breakage after hooks have been run, and we already cause such breakage with config/chroot_local-hooks/99-zzz_runtime_apt_proxy I think, so maybe we could as well do an elaborate s,http://,tor://, in APT sources.

#2 Updated by intrigeri about 5 years ago

  • Status changed from Confirmed to In Progress
  • Target version changed from Hardening_M1 to Tails_1.3
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA
  • Feature Branch set to feature/8194-APT-socks

The shim works fine. Passes the apt, build and firewall_leaks automatic test suite features. Retargetting to 1.3, then :)

We should try to replace this trick with proper use of apt-transport-tor once we are based on Jessie.

#3 Updated by intrigeri about 5 years ago

  • Related to Feature #8198: Replace tor+http shim with apt-transport-tor added

#4 Updated by intrigeri about 5 years ago

Incidentally, this branch fixes the APT errors we've been seeing in the build log since the migration to Wheezy.

#5 Updated by intrigeri about 5 years ago

  • Blocks Feature #5307: Fix the Wheezy build in a nicer way added

#6 Updated by alant about 5 years ago

  • Status changed from In Progress to 11
  • QA Check changed from Ready for QA to Pass

Merged thanks!

#7 Updated by BitingBird almost 5 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF