Project

General

Profile

Bug #8189

Patch to /etc/default/intel-microcode needs to be updated

Added by intrigeri over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Hardware support
Target version:
Start date:
10/31/2014
Due date:
% Done:

100%

Feature Branch:
bugfix/8189-intel-microcode-v3
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

The build of Tails ISOs is currently broken since intel-microcode 3.20140913.1~bpo70+1 reached wheezy-backports, due to our patch against /etc/default/intel-microcode not applying anymore.

Associated revisions

Revision 171c097e (diff)
Added by Tails developers over 5 years ago

Update patch to include all Intel CPU microcodes (Closes: #8189).

First, make it actually apply on current /etc/default/intel-microcode.

Second, keep using IUCODE_TOOL_SCANCPUS=no, as we still want to include all
microcodes, not only the one(s) for the build machine's CPU.

Third, use forced early mode for IUCODE_TOOL_INITRAMFS:

  • We can't use non-early initramfs mode anymore, since support for it has
    been removed.
  • We could not use "early" mode with the previous version of the
    intel-microcode packaging, since it only supported building on Intel CPU.
  • Quoting debian/changelog: "early" mode now allows a "non-Intel box to
    generate an early initramfs with microcode for an Intel box", and "on auto
    mode, do nothing in a non-intel box. In forced "early" mode, attempt to run
    iucode-tool".

So, this introduces a change in behaviour, but that's the best supported one,
the most robust one, and the one we wanted to use previously but could not.

History

#1 Updated by intrigeri over 5 years ago

  • Assignee set to intrigeri

Giving it a try.

#2 Updated by intrigeri over 5 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • Feature Branch set to bugfix/8189-intel-microcode-v3

#3 Updated by intrigeri over 5 years ago

  • Assignee changed from intrigeri to anonym
  • % Done changed from 10 to 50
  • QA Check set to Ready for QA

Assigning to the RM, since this fixes build breakage.

#4 Updated by anonym over 5 years ago

  • Status changed from In Progress to 11
  • Assignee deleted (anonym)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

#5 Updated by BitingBird over 5 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF