Project

General

Profile

Bug #8186

Pidgin's AppArmor profile prevents opening links in the Tor Browser

Added by anonym almost 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
10/29/2014
Due date:
% Done:

100%

Feature Branch:
bugfix/8186-pidgin-http-links
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Instant Messaging

Description

I get the following in syslog:

audit: type=1400 audit(1413898737.792:72): apparmor="DENIED" operation="exec" profile="/usr/bin/pidgin" name="/usr/local/bin/tor-browser" pid=9789 comm="pidgin" requested_mask="x" denied_mask="x" fsuid=1000 ouid=0

This is a regression since the introduction of AppArmor in Tails 1.2.

Associated revisions

Revision ee4eefc8 (diff)
Added by Tails developers almost 5 years ago

AppArmor: allow Pidgin to run Tor Browser unconfined, with scrubbed environment (Closes: #8186).

We have no Tor Browser profile yet, and it won't work if we make it inherit
Pidgin's confinement, hence we allow Pidgin to run it unconfined. We'll want to
revert this commit once we confine Tor Browser (#5525).

History

#1 Updated by BitingBird almost 5 years ago

  • Category set to 213
  • Priority changed from Normal to Elevated

Setting priority as elevated, since it's a regression.

#2 Updated by intrigeri almost 5 years ago

  • Assignee set to intrigeri

#3 Updated by intrigeri almost 5 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • Feature Branch set to bugfix/8186-pidgin-http-links

#4 Updated by intrigeri almost 5 years ago

  • Assignee deleted (intrigeri)
  • % Done changed from 10 to 50
  • QA Check set to Ready for QA

#5 Updated by anonym almost 5 years ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

#6 Updated by BitingBird almost 5 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF