Project

General

Profile

Feature #8163

Feature #6739: Add Electrum bitcoin client to Tails

Write user documentation for Electrum

Added by anonym over 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
10/20/2014
Due date:
% Done:

100%

Feature Branch:
feature/6739-install-electrum
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:

Description

We might want to get inspiration from, or link to one of these:

Associated revisions

Revision d8233b4c (diff)
Added by Tails developers almost 5 years ago

Remove Electrum from FAQ (Will-fix: #8163)

History

#1 Updated by anonym almost 5 years ago

Gentle ping, since writing the user docs is the only thing blocking electrum from inclusion. sajolida, do you think you'll have time to get this ready in time for Tails 1.3 (the feature freeze is currently 2015-02-11)?

#2 Updated by sajolida almost 5 years ago

Yes, I think that I'll make it. I have lots of tickets for 1.3 but right now I try to focus on the coding ones, then I'll tackle the documentation ones. I'll have some quality working time the week before the freeze so that should work.

#3 Updated by Tails almost 5 years ago

  • Status changed from Confirmed to In Progress

Applied in changeset commit:f23fa32ebdd9efbd7de147b9e7bd1a86bae7ac0c.

#4 Updated by sajolida almost 5 years ago

  • Assignee changed from sajolida to anonym
  • QA Check changed from Dev Needed to Ready for QA

Mostly done in 0869606. Please have a look.

#5 Updated by BitingBird almost 5 years ago

I think it's pretty good, but maybe you should mention to first enable the persistence option, then reboot before starting electrum?

And maybe put a link to https://en.wikipedia.org/wiki/Bitcoin (not sure, but might be a good idea).

#6 Updated by anonym almost 5 years ago

sajolida wrote:

Mostly done in 0869606. Please have a look.

Thanks! I'll have a closer look later this week. However, I cannot merge the branch since it contains my code, which some one else has to review.

BitingBird wrote:

I think it's pretty good, but maybe you should mention to first enable the persistence option, then reboot before starting electrum?

Note that my implementation adds a wrapper around electrum that checks whether its persistence preset is enabled, and warns the user if it isn't.

And maybe put a link to https://en.wikipedia.org/wiki/Bitcoin (not sure, but might be a good idea).

Indeed, the first instance of "bitcoin", perhaps?

#7 Updated by sajolida almost 5 years ago

Done in 2253b48.

#8 Updated by BitingBird almost 5 years ago

  • % Done changed from 0 to 50

#9 Updated by anonym almost 5 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (anonym)
  • QA Check changed from Ready for QA to Pass

#10 Updated by anonym almost 5 years ago

  • % Done changed from 50 to 100

#11 Updated by sajolida almost 5 years ago

  • Status changed from Resolved to Confirmed
  • QA Check changed from Pass to Dev Needed
  • Feature Branch set to feature/6739-install-electrum

I'm not sure whether this is the correct procedure. But we've been submitted to improvements to the documentation see 2ba009a and 4e69220.

I still want to rephrase them a bit before asking for a new review and merge in time for 1.3.

#12 Updated by intrigeri almost 5 years ago

  • Status changed from Confirmed to In Progress
  • Assignee set to sajolida
  • % Done changed from 100 to 70

#13 Updated by sajolida almost 5 years ago

  • Assignee deleted (sajolida)
  • QA Check changed from Dev Needed to Ready for QA

That's ready for review now, see 2ba009a..fb2f6f0.

#14 Updated by sajolida almost 5 years ago

I added some more commits today, see 5c3061d..27f8f68.

#15 Updated by anonym almost 5 years ago

  • Status changed from In Progress to 11
  • % Done changed from 70 to 100
  • QA Check changed from Ready for QA to Pass

Merged! I think it looks very good, and certainly better than without those warnings/tips.

#16 Updated by BitingBird almost 5 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF