Project

General

Profile

Feature #8157

Feature #7930: Support WebDAV

Test our WebDAV credentials

Added by sajolida over 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
10/19/2014
Due date:
% Done:

100%

Feature Branch:
Type of work:
Test
Blueprint:
Starter:
Affected tool:

Description

Now that we have WebDAV credentials, someone should test them in Tails.

I would start testing them:

  • from Nautilus
  • from Places → Connect to server.
  • both WebDAV and WebDAVs

I'll see if someone from frontdesk is interested.


Related issues

Blocks Tails - Feature #7932: Write manual tests for WebDAV Confirmed 09/22/2014
Blocks Tails - Feature #7933: Write automated tests for WebDAV Confirmed 09/22/2014

History

#1 Updated by sajolida over 5 years ago

#2 Updated by sajolida over 5 years ago

#3 Updated by sajolida over 5 years ago

  • Description updated (diff)

#4 Updated by sajolida over 5 years ago

  • Description updated (diff)

#5 Updated by sajolida over 5 years ago

  • Assignee set to emmapeel

#6 Updated by BitingBird almost 5 years ago

emmapeel, any news on that? It's been 6 months...

#7 Updated by emmapeel almost 5 years ago

  • Assignee deleted (emmapeel)

I cannot connect to our testing WebDAV from Tails, but I cannot connect from Debian Jessie neither.

Not sure if it is a problem on the testing server side, on the new Nautilus interface, as the user we have has an @ in the username and that should be part of the server line in nautilus (webdavs://user:password@server/folder) or what, but I cannot say it is a Tails problem.

#8 Updated by sajolida almost 5 years ago

  • Assignee set to emmapeel

Did you try as instructed here: http://www.autistici.org/en/stuff/man_web/webdav.html (both in Tails and a regular Debian)?

#9 Updated by intrigeri almost 5 years ago

I cannot connect to our testing WebDAV from Tails, but I cannot connect from Debian Jessie neither.

It would be good to tell exactly what happens.

#10 Updated by emmapeel almost 5 years ago

With Nautilus, message is 'HTTP error: Cannot connect to destination'
And something along those lines in Debian too.

With cadaver, I can connect with torify cadaver https://serveraddress but authentication fails, "Could not authenticate to server: rejected Basic challenge"
Also fails with Debian, without torify...

With davfs, I get Could not resolve hostname `servername': Host not found and if I add tor+ to the URL it gives me 'invalid URL'

#11 Updated by sajolida almost 5 years ago

Since that's quite more complicated that it seems at first sight, I
think that you should first get it work in GNOME in Debian (and then
compare with the same technique in Tails).

Contact autistici for debugging if needed. I trust them to have a
working system for Debian user but maybe there's something wrong in the
credentials they gave us.

#12 Updated by emmapeel almost 5 years ago

Ok, there was a problem with the password, now I can connect from Tails with cadaver, as this:

torify cadaver https://servername

I can connect from Debian Jessie with Nautilus too, but not from Tails. Not even running torify nautilus.

The message in Nautilus is 'HTTP Error: Cannot connect to destination'

#13 Updated by emmapeel almost 5 years ago

  • Assignee deleted (emmapeel)

#14 Updated by intrigeri almost 5 years ago

I can connect from Debian Jessie with Nautilus too, but not from Tails. Not even running torify nautilus.

The message in Nautilus is 'HTTP Error: Cannot connect to destination'

I suspect that's because Nautilus is already running (and managing the Desktop).

Would it work with:

nautilus --quit && torsocks nautilus

?

#15 Updated by intrigeri almost 5 years ago

  • Assignee set to emmapeel

#16 Updated by intrigeri almost 5 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 30

#17 Updated by emmapeel almost 5 years ago

  • Assignee changed from emmapeel to intrigeri

neither torsocks not torify option worked with Nautilus, even killing the app. Same error: 'HTTP Error: Cannot connect to destination (servername)'

#18 Updated by intrigeri almost 5 years ago

Confirmed.

Note that Nautilus doesn't connect itself to the WebDAV server, it instead spawns /usr/lib/gvfs/gvfsd-dav. If Nautilus were running gvfsd-dav directly, torsocks would apply and it would work, so I suspect that it's instead spawned indirectly, e.g. via D-Bus activation, so GNOME proxy settings apply and it explains the error we're seeing.

So, from here:

  • we could document that using a command-line client like cadaver with torsocks works, and that using Nautilus doesn't (normal prio);
  • we could research how to make gvfsd-dav (and some other gvfs backends perhaps) work, without giving access to the network to all kinds of GNOME applications -- I suspect that's tricky, and IMO that's low prio.

#19 Updated by intrigeri almost 5 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 30 to 100

Also available in: Atom PDF