Project

General

Profile

Bug #8153

'open the URL' doesn't open it in the Tor Browser

Added by goupille about 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
10/17/2014
Due date:
% Done:

100%

Feature Branch:
bugfix/8153-set-gnome-browser-mime-types
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Browser

Description

on Tails 1.2, right click on an URL have multiple results (tries to open it with gedit and crashes it, an "HTTP error: Cannot connect to the destination", or just no effect at all).

I just tested it on 1.1.1, it works well

This has been reported to our help desk as affecting Claws Mail, and KeePassX amongst others.

fix_file_handler.patch View (993 Bytes) sanic, 10/18/2014 10:58 PM


Related issues

Duplicated by Tails - Bug #8162: Claws mail not opening links on TBB Duplicate 10/20/2014
Duplicated by Tails - Bug #8197: gnome-open doesn't handle input correctly in Tails 1.2 Duplicate 11/03/2014
Duplicated by Tails - Bug #8361: Opening web URL from other applications stopped working Duplicate 12/02/2014

Associated revisions

Revision 0cfb2210 (diff)
Added by Tails developers about 5 years ago

Use the Tor Browser for MIME type that GNOME associates with Iceweasel (Closes: #8153).

History

#1 Updated by intrigeri about 5 years ago

  • Assignee set to anonym
  • Priority changed from Normal to Elevated
  • Target version set to Tails_1.2.1

Hi anonym, could you please have a look?

#2 Updated by sanic about 5 years ago

The problem is caused by /etc/gnome/defaults.list referencing iceweasel when it should be referencing tor-browser. Attached is a small patch to fix it.

#3 Updated by BitingBird about 5 years ago

  • Status changed from New to In Progress
  • QA Check set to Ready for QA

#4 Updated by anonym about 5 years ago

  • Category set to 176
  • Assignee changed from anonym to intrigeri
  • % Done changed from 0 to 50
  • Feature Branch set to feature/8153-set-gnome-browser-mime-types
  • Type of work changed from Research to Code

Thanks, sanic, for identifying the solution!

While we could add your patch (with chroot/ added to the diffed paths at the top) to config/chroot_local-patches, I think I prefer to do this change around the already existing code that configures the system-wide browser:

diff --git a/config/chroot_local-hooks/10-tbb b/config/chroot_local-hooks/10-tbb
index d8e6b5f..2a0903f 100755
--- a/config/chroot_local-hooks/10-tbb
+++ b/config/chroot_local-hooks/10-tbb
@@ -216,3 +216,4 @@ chmod -R a+rX "${TBB_INSTALL}" "${TBB_PROFILE}" "${TBB_EXT}" 
 # Make the Tor Browser into the system's default web browser
 update-alternatives --install /usr/bin/x-www-browser x-www-browser /usr/local/bin/tor-browser 99
 update-alternatives --install /usr/bin/gnome-www-browser gnome-www-browser /usr/local/bin/tor-browser 99
+sed -i 's/\<iceweasel\.desktop\>/tor-browser.desktop/' /etc/gnome/defaults.list

Done in the branch feature/8153-set-gnome-browser-mime-types. Would you review'n'merge (into stable and devel) this, intrigeri? Otherwise, please unassign yourself.

#5 Updated by anonym about 5 years ago

  • Feature Branch changed from feature/8153-set-gnome-browser-mime-types to bugfix/8153-set-gnome-browser-mime-types

Renamed branch since this is a bugfix. Also merged into experimental now.

#6 Updated by sajolida about 5 years ago

  • Related to Bug #8162: Claws mail not opening links on TBB added

#7 Updated by BitingBird about 5 years ago

  • Related to deleted (Bug #8162: Claws mail not opening links on TBB)

#8 Updated by BitingBird about 5 years ago

  • Duplicated by Bug #8162: Claws mail not opening links on TBB added

#9 Updated by intrigeri about 5 years ago

We should check that this fixes #8162 as well.

#10 Updated by intrigeri about 5 years ago

  • Assignee deleted (intrigeri)

anonym wrote:

Would you review'n'merge (into stable and devel) this, intrigeri? Otherwise, please unassign yourself.

Not sure yet. Please ask for review'n'merges on tails-dev@, so that others have greater chances to notice and give a hand.

#11 Updated by sajolida about 5 years ago

  • Description updated (diff)

#12 Updated by intrigeri about 5 years ago

  • Assignee set to intrigeri

#13 Updated by intrigeri about 5 years ago

  • Assignee changed from intrigeri to anonym
  • QA Check changed from Ready for QA to Dev Needed

See test results posted on -dev@.

#14 Updated by intrigeri about 5 years ago

  • Assignee changed from anonym to intrigeri
  • QA Check changed from Dev Needed to Ready for QA

#15 Updated by intrigeri about 5 years ago

  • Status changed from In Progress to 11
  • Assignee deleted (intrigeri)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

#16 Updated by intrigeri about 5 years ago

  • Duplicated by Bug #8197: gnome-open doesn't handle input correctly in Tails 1.2 added

#17 Updated by BitingBird about 5 years ago

  • Duplicated by Bug #8361: Opening web URL from other applications stopped working added

#18 Updated by BitingBird about 5 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF