Project

General

Profile

Bug #8152

I2P browser doesn't start after incremental upgrade to Tails 1.2

Added by goupille about 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
10/17/2014
Due date:
% Done:

100%

Feature Branch:
bugfix/8158-stacked-rootfs-vs-chroot-browsers
Type of work:
Code
Blueprint:
Starter:
Affected tool:
I2P

Description

when lauching the i2p browser, the warning show up but multiple users waited more thant 30 minutesand the i2p browser didn't start. I found that in the logs (.xsession-errors):

Everything is Ok
unzip: cannot find or open /var/lib/i2p-browser/chroot//usr/local/lib/tor-browser/browser/omni.ja, /var/lib/i2p-browser/chroot//usr/local/lib/tor-browser/browser/omni.ja.zip or /var/lib/i2p-browser/chroot//usr/local/lib/tor-browser/browser/omni.ja.ZIP.
sed: can't read /tmp/tmp.vJsqnaMTPH/chrome/en-US/locale/branding/brand.dtd: No such file or directory

fix_i2p_browser_chroot.patch View (699 Bytes) sanic, 10/20/2014 09:23 AM

fix_i2p_browser_chroot2.patch View (899 Bytes) sanic, 10/20/2014 12:02 PM


Related issues

Related to Tails - Bug #8158: Unsafe Browser does not start Resolved 10/19/2014

Associated revisions

Revision 70701bbb (diff)
Added by Tails developers about 5 years ago

Use the correct stack of rootfs:s for the chroot browsers (Closes: #8152, #8152).

After installing incremental upgrades Tails' root filesystem consists
of a stack squashfs:s, not only filesystem.squashfs. When not stacking
them correct we may end up using the Tor Browser (Firefox) from an
older version of Tails, or with no Tor Browser at all, as in the
upgrade from Tails 1.1.2 to 1.2, when we migrated from Iceweasel to
the Tor Browser.

Based on patch contributed by sanic.

History

#1 Updated by BitingBird about 5 years ago

  • Category set to 180

#2 Updated by intrigeri about 5 years ago

  • Subject changed from I2p browser doesn't start to I2P browser doesn't start
  • Assignee set to kytv
  • Priority changed from Normal to Elevated
  • Target version set to Tails_1.2.1

kytv, may you please have a look? Assuming it worked back when anonym merged your work for 1.2, I guess it was caused by one of last changes for the migration to TBB / FF31.

#3 Updated by intrigeri about 5 years ago

  • Related to Bug #8158: Unsafe Browser does not start added

#4 Updated by intrigeri about 5 years ago

  • Assignee changed from kytv to anonym

anonym, I guess the explanation on #8158 applies here too. There's a patch there.

#5 Updated by sanic about 5 years ago

Here's a fix for the I2P browser problem, which has the same cause as #8158.

#6 Updated by sanic about 5 years ago

Updated patch, confirmed working on my computer. The patch is identical to the final one for #8158 except for referencing i2p-browser instead of unsafe-browser.

#7 Updated by anonym about 5 years ago

  • Assignee deleted (anonym)
  • Feature Branch set to bugfix/8158-stacked-rootfs-vs-chroot-browsers
  • Type of work changed from Research to Code

The patch needed some love. Please review'n'merge!

(BTW, my test in #8158-13 also verified that the I2P Browser works after incremental upgrades.)

#8 Updated by intrigeri about 5 years ago

  • Assignee set to intrigeri

#9 Updated by intrigeri about 5 years ago

  • Status changed from In Progress to 11
  • Assignee deleted (intrigeri)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

#10 Updated by intrigeri about 5 years ago

  • Subject changed from I2P browser doesn't start to I2P browser doesn't start after incremental upgrade to Tails 1.2

#11 Updated by BitingBird about 5 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF