Project

General

Profile

Bug #8091

Support automated testing of old ISO images with different set of persistence presets

Added by anonym over 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
Start date:
10/13/2014
Due date:
% Done:

100%

Feature Branch:
test/8091-improve-old-iso-testing
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Let's say we are testing an image that just added a new persistence preset to t-p-s. At the moment, if the static list of supported persistence presets (defined in features/step_definitions/usb.rb) has been adapted for the iso being tested, then several tests in usb_install.feature will fail for the old iso. The reason is that the new entries in the static list of presets will cause tests for the old iso that will fail, since they're not present.


Related issues

Blocks Tails - Feature #6739: Add Electrum bitcoin client to Tails Resolved 10/20/2014

Associated revisions

Revision f4259ec9
Added by Tails developers about 5 years ago

Merge remote-tracking branch 'origin/test/8091-improve-old-iso-testing' into devel

Fix-committed: #8091

History

#1 Updated by anonym over 5 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from anonym to intrigeri
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA
  • Feature Branch set to test/8091-improve-old-iso-testing

Assigning to intrigeri since he's the only other developer with recent experience with the automated test suite.

#2 Updated by intrigeri over 5 years ago

  • Target version set to Tails_1.3

#6 Updated by intrigeri over 5 years ago

  • Subject changed from Support automated testing of old isos with different set of persistence presets to Support automated testing of old ISO images with different set of persistence presets

#7 Updated by intrigeri about 5 years ago

  • Assignee changed from intrigeri to anonym
  • QA Check changed from Ready for QA to Dev Needed

Sent initial code review on -dev@.

#8 Updated by intrigeri about 5 years ago

  • Blocks Feature #6739: Add Electrum bitcoin client to Tails added

#10 Updated by anonym about 5 years ago

  • Assignee changed from anonym to intrigeri
  • % Done changed from 50 to 60
  • QA Check changed from Dev Needed to Ready for QA

Concerns raised on tails-dev@ should be fixed now.

#11 Updated by Tails about 5 years ago

  • Status changed from In Progress to 11
  • % Done changed from 60 to 100

Applied in changeset commit:12fe245fc6c960a6abe2ad51f3f62f4d1f9bf4ff.

#12 Updated by intrigeri about 5 years ago

  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

#13 Updated by BitingBird almost 5 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF