Project

General

Profile

Bug #8087

GNOME screenshot does not save files

Added by matsa about 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
10/13/2014
Due date:
% Done:

100%

Feature Branch:
matsa:bugfix/8087-gnome-screenshot-save-to-home-folder
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

The PrintScreen hotkey is set up to save screenshots in /.

As there is no right to write in this folder, those screenshots are not saved, and user get no error message.


Related issues

Duplicated by Tails - Bug #8487: GNOME screenshot does not save files anywhere Duplicate 12/25/2014

Associated revisions

Revision 7ddc2ec1 (diff)
Added by Tails developers almost 5 years ago

set gnome-screenshot preferences to save in /home/amnesia. will-fix #8087

History

#1 Updated by matsa about 5 years ago

  • Status changed from New to In Progress

This can be fixed with something like

gsettings set org.gnome.gnome-screenshot auto-save-directory 'file:///home/amnesia/Desktop'

#2 Updated by intrigeri about 5 years ago

  • Status changed from In Progress to Confirmed
  • Priority changed from Normal to Elevated

Raising priority, as this seems to be a regression caused by the migration to Wheezy.

#3 Updated by subkeys about 5 years ago

executing the command provided by matsa above corrected the issue in the latest version of Tails.

#4 Updated by intrigeri about 5 years ago

Anyone who wants to fix that: start by adding the aforementionned key/value to config/chroot_local-includes/etc/dconf/db/local.d/00_Tails_defaults, build an ISO, test.

#5 Updated by BitingBird almost 5 years ago

  • Duplicated by Bug #8487: GNOME screenshot does not save files anywhere added

#6 Updated by BitingBird almost 5 years ago

There is some discussion in the duplicate #8487 too.

#7 Updated by u almost 5 years ago

  • Subject changed from PrintScreen hotkey is not working anymore to GNOME screenshot does not save files

Renaming this as the title seems to be misleading. The button works. Simply the files are not saved.

#8 Updated by matsa almost 5 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA
  • Feature Branch set to matsa:8087-gnome-screenshot-save-to-home-folder

#9 Updated by intrigeri almost 5 years ago

  • Feature Branch changed from matsa:8087-gnome-screenshot-save-to-home-folder to matsa:bugfix/8087-gnome-screenshot-save-to-home-folder

#10 Updated by intrigeri almost 5 years ago

  • Target version set to Tails_1.2.3

#11 Updated by Tails almost 5 years ago

Applied in changeset commit:efd8d8310eded3242d8f7430e85a5c8baa5a773b.

#12 Updated by anonym almost 5 years ago

  • Status changed from In Progress to 11
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

#13 Updated by BitingBird almost 5 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF