Project

General

Profile

Feature #8083

Fix automatic upgrades on Jessie

Added by sajolida over 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
10/12/2014
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Upgrader

Description

I tested tails-upgrade-frontend on Jessie and it returned "The system is up-to-date". But it might be worth testing a real upgrade path.


Related issues

Related to Tails - Bug #8263: Deal with memory requirements check in tails-upgrade-frontend-wrapper vs Jessie Resolved 11/14/2014
Blocks Tails - Feature #9373: Make tails-iuk support overlayfs Resolved

History

#1 Updated by intrigeri over 5 years ago

  • Category set to 178

#2 Updated by intrigeri about 5 years ago

  • Assignee set to anonym
  • Priority changed from Normal to Elevated

#3 Updated by intrigeri over 4 years ago

#4 Updated by intrigeri about 4 years ago

  • Related to Bug #8263: Deal with memory requirements check in tails-upgrade-frontend-wrapper vs Jessie added

#5 Updated by intrigeri about 4 years ago

  • Assignee changed from anonym to intrigeri

I'll steal this one from anonym, so that he can focus on the test suite.

#6 Updated by intrigeri about 4 years ago

  • Status changed from Confirmed to In Progress

This fails:

    # upgrade syslinux' ldlinux.sys
    my $syslinux = file($self->liveos_mountpoint, qw{utils linux syslinux});
    run_as_root($syslinux, qw{-d syslinux}, $self->system_partition_file)
        if -e $syslinux;

with:

stderr:
Attribute (system_partition) does not pass the type constraint because: Validation failed for 'Str' with value undef at accessor Tails::RunningSystem::system_partition (defined at /usr/share/perl5/Tails/RunningSystem.pm line 78) line 18
    Tails::RunningSystem::system_partition('Tails::RunningSystem=HASH(0xbd7bc04)') called at /usr/share/perl5/Tails/RunningSystem.pm line 223
    Tails::RunningSystem::_build_system_partition_file('Tails::RunningSystem=HASH(0xbd7bc04)') called at accessor Tails::RunningSystem::system_partition_file (defined at /usr/share/perl5/Tails/RunningSystem.pm line 82) line 11
    Tails::RunningSystem::system_partition_file('Tails::RunningSystem=HASH(0xbd7bc04)') called at /usr/lib/i386-linux-gnu/perl5/5.20/Moose/Meta/Method/Delegation.pm line 109
    Tails::IUK::Install::system_partition_file('Tails::IUK::Install=HASH(0xbd0da58)') called at /usr/share/perl5/Tails/IUK/Install.pm line 220
    Tails::IUK::Install::run('Tails::IUK::Install=HASH(0xbd0da58)') called at /usr/bin/tails-install-iuk line 22

#7 Updated by intrigeri about 4 years ago

  • % Done changed from 0 to 10

intrigeri wrote:

This fails:

tails-perl5lib 0.8.12-1+jessie3 should fix it, will run a full test with it.

#8 Updated by intrigeri about 4 years ago

  • Subject changed from Test automatic upgrades on Jessie to Fix automatic upgrades on Jessie
  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 10 to 100
  • Type of work changed from Test to Code

Also available in: Atom PDF