Project

General

Profile

Bug #8059

Windows Camouflage automated tests sometimes failed due to differently ordered icons in the notification area

Added by intrigeri over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
Start date:
10/11/2014
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
test/8059-more-robust-windows-systray
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

The expected WindowsSysTray.png has (from left to right): keyboard, OpenPGP, notifications (1), sound. I've just seen instead: keyboard, OpenPGP, sound, notifications (1). I guess we could look for keyboard and OpenPGP together, and then separately look for the sound icon. Not sure looking for the notifications icon is good, as depending on various races, there can be different numbers in there -- if we do that, IMO we should not include the number of notifications in the expected image.


Subtasks

Bug #7233: How to deal with tests expected to fail?Resolved

Bug #10281: Document how we deal with tests expected to failResolved

Bug #8697: Step "I update APT using apt-get" succeeds even if apt-get update failedResolved

Bug #8698: Step "I open the address "([^"]*)" in the Tor Browser" is fragileResolved

Bug #8707: The automated test suite does not clean up when it's finishedResolved

Bug #8714: Step 'Tor is ready' fails randomlyResolved

Bug #8875: Make running applications from the GNOME menu more robust, againResolved

Bug #8876: "the I2P router console is ready" step can break due to too small timeoutResolved

Bug #8941: The remote shell server is racing against Tails GreeterResolved

Bug #8950: Test suite fails if features/misc_files/* or parent directories have strict permissionsResolved

Bug #8928: "unclutter" can cause spurious errors with some configurationsResolved

Feature #9009: Test switching from unclutter to hhp in the test suiteResolved

Bug #9072: Pidgin IRC tests often fail due to OFTC Tor blockingResolved

Bug #8907: storage_helper.rb does not check available disk spaceResolved

Bug #9095: Seahorse tests lack robustnessResolved

Bug #9343: Make seahorse tests more robust by using less keyboard shortcutsResolved

Bug #9344: Sometimes Seahorse's Find keys dialog cannot be found during testsResolved

Bug #9345: Consider switching OpenPGP key serverResolved

Bug #9346: Test if switching to a more stable OpenPGP key server improves the Seahorse testsResolved

Bug #9347: Investigate if Seahorse has hardcoded timeouts causing transient network issuesRejected

Bug #9139: Test suite stalled, lots of virt-viewer defunct processesResolved

Bug #9140: ISO selection in test suite "Upgrade from ISO" is fragileRejected

Bug #9317: Pidgin IRC test can fail with buddy list window over conversation oneResolved

Bug #9329: fillram sometimes doesn't completeResolved

Associated revisions

Revision 6c43a02d (diff)
Added by Tails developers over 4 years ago

Look for individual systray applets, to avoid relying on their ordering (Closes: #8059).

History

#1 Updated by intrigeri over 4 years ago

  • Target version set to Hardening_M1

(blocks a 3.0 goal)

#2 Updated by intrigeri over 4 years ago

  • Blocks Feature #5288: Run the test suite automatically on autobuilt ISOs added

#3 Updated by intrigeri over 4 years ago

  • Assignee set to anonym
  • QA Check set to Info Needed

Trying to assess the priority of this bug: anonym, do you see it often? It seems I've affected by it very often these days (rough guess: 40-80% of the time). Feel free do de-assign the ticket from you after answering.

#4 Updated by anonym over 4 years ago

  • Assignee changed from anonym to intrigeri
  • Target version changed from Hardening_M1 to Tails_1.2.1
  • QA Check changed from Info Needed to Dev Needed

intrigeri wrote:

Trying to assess the priority of this bug: anonym, do you see it often? It seems I've affected by it very often these days (rough guess: 40-80% of the time). Feel free do de-assign the ticket from you after answering.

I've seen it a few times, so let's fix this sooner rather than later. I agree that looking for the individual systray icons, excluding the notification one (due to the counter), seems like a reasonable fix.

#5 Updated by intrigeri over 4 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • Feature Branch set to test/8059-more-robust-windows-systray

#9 Updated by intrigeri over 4 years ago

  • Assignee deleted (intrigeri)
  • % Done changed from 10 to 50
  • QA Check changed from Dev Needed to Ready for QA

#10 Updated by anonym over 4 years ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

#11 Updated by BitingBird over 4 years ago

  • Status changed from Fix committed to Resolved

#12 Updated by intrigeri over 4 years ago

  • Blocks deleted (Feature #5288: Run the test suite automatically on autobuilt ISOs)

#13 Updated by intrigeri over 4 years ago

  • Parent task set to #8539

Also available in: Atom PDF