Project

General

Profile

Bug #8051

OpenPGP Applet is unusable on GNOME Shell

Added by sajolida over 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
10/09/2014
Due date:
% Done:

100%

Feature Branch:
feature/jessie
Type of work:
Code
Blueprint:
Starter:
Affected tool:
OpenPGP Applet

Description

There is no OpenPGP Applet on the desktop in Jessie.

Executing gpgApplet from the command line produces the following trace:

Can't locate Any/Moose.pm in @INC (you may need to install the Any::Moose module) (@INC contains: /etc/perl /usr/local/lib/i386-linux-gnu/perl/5.20.0 /usr/local/share/perl/5.20.0 /usr/lib/i386-linux-gnu/perl5/5.20 /usr/share/perl5 /usr/lib/i386-linux-gnu/perl/5.20 /usr/share/perl/5.20 /usr/local/lib/site_perl .) at /usr/local/lib/site_perl/gpgApplet/GnuPG/Interface.pm line 2.
BEGIN failed--compilation aborted at /usr/local/lib/site_perl/gpgApplet/GnuPG/Interface.pm line 2.
Compilation failed in require at /usr/local/bin/gpgApplet line 37.
BEGIN failed--compilation aborted at /usr/local/bin/gpgApplet line 37.


Related issues

Related to Tails - Feature #7433: Turn Tails OpenPGP Applet into a standalone application Duplicate 06/22/2014
Blocks Tails - Bug #8052: Test OpenPGP Applet documentation in Jessie Resolved 10/09/2014

Associated revisions

Revision 69c51629 (diff)
Added by Tails developers over 4 years ago

Explicitly install libany-moose-perl (Closes: #8051).

It's needed by our OpenPGP applet. On Wheezy, this package was pulled by some
other dependency. This is not the case anymore on Jessie.

History

#1 Updated by sajolida over 4 years ago

  • Blocks Bug #8052: Test OpenPGP Applet documentation in Jessie added

#2 Updated by intrigeri over 4 years ago

  • Assignee set to intrigeri

#3 Updated by intrigeri over 4 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • Feature Branch set to feature/jessie

Possibly fixed in commit 52cd2175e.

#4 Updated by intrigeri over 4 years ago

  • Subject changed from No OpenPGP Applet in Jessie to OpenPGP Applet is unusable on GNOME Shell
  • Status changed from In Progress to Confirmed
  • Assignee deleted (intrigeri)

Indeed it now starts, but it's unusable (doesn't react to mouse clicks) since it hijacks the notification area. We should either turn it into a GNOME Shell extension, or into a standalone application (#7433).

#5 Updated by intrigeri over 4 years ago

  • Related to Feature #6507: Package our OpenPGP applet for Debian and maintain it there added

#6 Updated by intrigeri over 4 years ago

  • Related to Feature #7433: Turn Tails OpenPGP Applet into a standalone application added

#7 Updated by nodens over 4 years ago

Hi,

On my gnome-shell desktop (debian Sid), I work around this by using the "TopIcons" extension.
It is needed anyway for a lot of apps that use tray icons.

https://extensions.gnome.org/extension/495/topicons/

Turning the applet into a full application + dbus + extension would be better, but this is a lot of work and will probably take some time.

#8 Updated by intrigeri over 4 years ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 10 to 100

nodens wrote:

On my gnome-shell desktop (debian Sid), I work around this by using the "TopIcons" extension.

Thanks! That's what we've done in our feature/jessie branch.

Turning the applet into a full application + dbus + extension would be better, but this is a lot of work and will probably take some time.

I'll file a dedicated ticket about that.

#9 Updated by nodens almost 4 years ago

  • Related to deleted (Feature #6507: Package our OpenPGP applet for Debian and maintain it there)

#10 Updated by intrigeri almost 4 years ago

  • Affected tool set to OpenPGP Applet

Also available in: Atom PDF