Project

General

Profile

Feature #8047

Document the wipe features of Disks

Added by sajolida almost 5 years ago. Updated about 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
10/09/2014
Due date:
% Done:

10%

Feature Branch:
Type of work:
End-user documentation
Blueprint:
Starter:
Yes
Affected tool:

Description

Disks in Jessie now advertise a wipe feature. When you create a new partition it proposes to "overwrite exisiting data with zeroes".

We should investigate how does this work and how does it do compared to "wipe available disk space" in relation with #7118.


Related issues

Related to Tails - Feature #5323: Document a GUI way to securely erase Flash media via Gnome Disks Resolved

History

#1 Updated by intrigeri almost 5 years ago

  • Priority changed from Normal to Low

Not a blocker.

#2 Updated by intrigeri almost 4 years ago

  • Status changed from Confirmed to In Progress
  • Assignee set to sajolida
  • % Done changed from 0 to 10

sajolida wrote:

When you create a new partition it proposes to "overwrite exisiting data with zeroes".

In udisks2 2.1.6-2 (current sid, while Jessie has 2.1.3-5), the code lives in the erase_device function, in src/udiskslinuxblock.c, in udisks2 source code. See also populate_erase_combobox in gnome-disk-utility source code. Apparently, ATA erasure feature can be displayed if the drive supports it. The "with zeroes" feature does just what it says.

What other info do you need?

#3 Updated by intrigeri almost 4 years ago

Tested on sid (g-d-u 3.18.2-1), I like it a lot. Amazingly, the progress bar gives correct info.

#4 Updated by sajolida over 3 years ago

  • Subject changed from Consider documenting the wipe features of Disks to Document the wipe features of Disks
  • Assignee deleted (sajolida)
  • Priority changed from Low to Normal
  • Target version deleted (Tails_2.0)
  • Parent task deleted (#8043)
  • Type of work changed from Research to End-user documentation

All-right, let's do that. But not for the release as it's not a regression :)

That might fix #5323 but needs to be checked.

#5 Updated by sajolida over 3 years ago

  • Related to Feature #5323: Document a GUI way to securely erase Flash media via Gnome Disks added

#6 Updated by u about 2 years ago

  • Status changed from In Progress to Confirmed
  • Starter set to Yes

This would be an easy first task for doc writers to document this feature.

#8 Updated by u about 2 years ago

  • Status changed from Confirmed to Duplicate

I'm closing this ticket as a duplicate of #5323, where I reported the remaining tasks.

Also available in: Atom PDF