Project

General

Profile

Bug #8043

Feature #7584: Update documentation for Jessie

Update Disks documentation for Jessie

Added by sajolida about 5 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
10/09/2014
Due date:
% Done:

100%

Feature Branch:
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:

Description

In Jessie, the old Disk Utility has been rename as Disks and the interface changed a lot.

We need to update our documentation accordingly.

  • /doc/encryption_and_privacy/encrypted_volumes
  • /doc/first_steps/installation/manual/linux
  • /doc/first_steps/persistence/change_passphrase
  • /doc/first_steps/persistence/check_file_system
  • /doc/first_steps/persistence/copy
  • /doc/first_steps/reset/linux

Subtasks

Bug #8044: Update screenshots for GNOME Disks for JessieResolved

Bug #8045: Update path to GNOME Disks for JessieResolved

Bug #8046: Tails Installer crashes on JessieResolved

Feature #8048: Update encrypted volumes creation documentation to Jessie's GNOME DisksResolved

Feature #8050: Update safe removal instructions for JessieResolved

Bug #10799: Document checking the file system of the persistent storage using the command lineResolved

Bug #10810: Update access to encrypted volumes documentation for JessieResolved

Bug #10934: Update resetting with Linux for JessieResolved

Bug #10935: Update password changing of persistence for JessieResolved

Bug #10936: Update copying of persistent volume for JessieResolved

History

#1 Updated by sajolida about 5 years ago

  • Description updated (diff)

#2 Updated by intrigeri about 5 years ago

  • Target version set to Tails_2.0

#3 Updated by BitingBird almost 5 years ago

  • Subject changed from Update Disks documentation to Update Disks documentation for Jessie

#4 Updated by spriver almost 4 years ago

  • Assignee set to spriver

I could work on that in the next days and weeks. On which branch should I base my work?

#5 Updated by intrigeri almost 4 years ago

I could work on that in the next days and weeks.

Cool! I'll let sajolida comment if there's anything more you should know than what is written here already.

On which branch should I base my work?

feature/jessie

#6 Updated by sajolida almost 4 years ago

Nothing more than what's in the description already. But beware this is going to be quite some work! :)

#7 Updated by spriver almost 4 years ago

In GNOME Disks we have this little gear wheels as a menu for each disk in the right window pane after selecting it. Should we just call it "Menu" (or e.g. "Select the little gear wheels" or some such thing) or include a picture of this or agree on a different approach here?

#8 Updated by intrigeri almost 4 years ago

I would describe the icon (something gears) and explicitly state what its tooltip says, to make it unambiguous. But I'm by no means authoritative wrt. tech doc writing.

#9 Updated by spriver almost 4 years ago

intrigeri wrote:

I would describe the icon (something gears) and explicitly state what its tooltip says, to make it unambiguous. But I'm by no means authoritative wrt. tech doc writing.

e.g. "Click on the icon with the two gears and select Format... from the pull-down menu"?

#10 Updated by intrigeri almost 4 years ago

Something like this, yep.

#11 Updated by sajolida almost 4 years ago

I would describe the icon (something gears) and explicitly state what its tooltip says, to make it unambiguous.

Yeah, that's a bit how Google does, see:

https://labs.riseup.net/code/attachments/download/1062/gmail.png

#13 Updated by spriver almost 4 years ago

Should I also update the page /doc/first_steps/installation/manual/linux ? Does this make sense to update the page regarding to the new installation assistant?

#14 Updated by spriver almost 4 years ago

Another question: Shall the page for linux contain both instructions for resetting with and without a persistent partition since the procedures differ?

#15 Updated by sajolida almost 4 years ago

Please don't update /doc/first_steps/installation/manual/linux as the new instructions will replace this page.

What made you think that the resetting procedure differ with or without persistent storage as I can't find occurences of "persist*" in /doc/first_steps/reset/linux?

Meta: to be on the safe side, when asking question, it's better to reassign the ticket to whom you're asking the question to and mark the ticket as "QA Check: Info Needed".

#16 Updated by sajolida almost 4 years ago

  • Parent task set to #7584

#17 Updated by sajolida over 3 years ago

  • Status changed from Confirmed to In Progress

#18 Updated by sajolida over 3 years ago

  • Status changed from In Progress to Resolved

Done with all the subtasks, closing now!

#19 Updated by spriver about 3 years ago

  • Assignee deleted (spriver)

Also available in: Atom PDF