Project

General

Profile

Feature #8027

Ship OpenSSH from wheezy-backports

Added by Dr_Whax over 4 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
10/07/2014
Due date:
% Done:

0%

QA Check:
Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

A friendly cypherpunk asked whether Tails would like to ship the OpenSSH client from wheezy-backports. This backport supports:

  • ed25519 keys
  • chacha20-poly1305 as transport cipher
  • bcrypt stretching of keys at rest

I would personally like to see Tails ship an openssh client which supports the generation of non-nist crypto to ssh into services.

I'd gladly answer any questions or implement it in a branch.


Related issues

Related to Tails - Feature #7315: Remove custom SSH ciphers, MACs and HostKeyAlgorithms settings Resolved 05/27/2014

History

#1 Updated by intrigeri over 4 years ago

A friendly cypherpunk asked whether Tails would like to ship the OpenSSH client from wheezy-backports.

Fine with me. The backport seems to be maintained by the OpenSSH maintainer in Debian, which is confidence-inspiring.

#2 Updated by Dr_Whax over 4 years ago

Ok, i'll prepare a patch soon. I will also throw in an automated test, shall I move that to a separate ticket?

#3 Updated by intrigeri over 4 years ago

I will also throw in an automated test, shall I move that to a separate ticket?

No, let's say we'll take them together, or not at all :)

#4 Updated by Dr_Whax over 4 years ago

Sure, i'll give it a shot :-)

#5 Updated by sajolida over 4 years ago

  • Assignee set to Dr_Whax
  • Type of work changed from Discuss to Code

#6 Updated by intrigeri over 4 years ago

  • Related to Feature #7315: Remove custom SSH ciphers, MACs and HostKeyAlgorithms settings added

#7 Updated by intrigeri over 4 years ago

Dr_Whax wrote:

Ok, i'll prepare a patch soon.

Any news on that one, or better deassign yourself?

#8 Updated by intrigeri over 3 years ago

  • Status changed from Confirmed to Rejected

Next Tails will be based on Jessie so this is not relevant anymore. But indeed we should update our ciphers etc. list: #7315.

Also available in: Atom PDF