Project

General

Profile

Bug #8009

Bug #8686: Sometimes notification-daemon aborts, causing desktop notifications to not be displayed

Feature #9332: Test that notification-daemon is running

The Unsafe Browser tests sometimes fail due to too fast keyboard interaction

Added by intrigeri almost 5 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
Start date:
10/05/2014
Due date:
% Done:

100%

Feature Branch:
feature/tor-browser-bundle
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

In this code:

Then /^I cannot configure the Unsafe Browser to use any local proxies$/ do
  next if @skip_steps_while_restoring_background
  @screen.wait_and_click("UnsafeBrowserWindow.png", 10)
  sleep 0.5
  # First we open the proxy settings page to prepare it with the
  # correct open tabs for the loop below.
  @screen.type("e", Sikuli::KeyModifier.ALT)
  @screen.type("n")
  @screen.wait('UnsafeBrowserPreferences.png', 10)

I've seen the "n" typing fail, most likely because the menu's keybindings having not been set up fast enough for it to trigger any action. I suggest we instead wait_and_click on the Preferences menu entry.


Subtasks

Associated revisions

Revision ad8815ad (diff)
Added by Tails developers almost 5 years ago

In the Unsafe Browser tests, rely on subtle timing less (Closes: #8009).

I've seen the "n" typing fail, most likely because the menu's keybindings having
not been set up fast enough for it to trigger any action. Better use
wait_and_click on the Preferences menu entry instead, which feels more robust.

History

#1 Updated by intrigeri almost 5 years ago

  • Blocks Feature #5288: Run the test suite automatically on autobuilt ISOs added

#2 Updated by intrigeri almost 5 years ago

  • Target version changed from Sustainability_M1 to Hardening_M1

Setting target version to the same one as the ticket it blocks (#5288).

#3 Updated by intrigeri almost 5 years ago

  • Status changed from Confirmed to In Progress
  • Assignee set to intrigeri
  • % Done changed from 0 to 10

#4 Updated by intrigeri almost 5 years ago

  • Assignee deleted (intrigeri)
  • Target version changed from Hardening_M1 to Tails_1.2
  • % Done changed from 10 to 50
  • QA Check set to Ready for QA
  • Feature Branch set to feature/apparmor

#5 Updated by intrigeri almost 5 years ago

  • Subject changed from The Unsafe Browser sometimes fails due to too fast keyboard interaction to The Unsafe Browser tests sometimes fail due to too fast keyboard interaction

#6 Updated by intrigeri almost 5 years ago

This problem was actually fixed already in the branch that migrates to the Tor Browser, so when merging feature/apparmor, the Tor Browser's branch solution shall be preferred, and likely at least one unused image introduced by feature/apparmor can be removed.

#7 Updated by anonym almost 5 years ago

  • QA Check deleted (Ready for QA)
  • Feature Branch changed from feature/apparmor to feature/tor-browser-bundle

#8 Updated by anonym almost 5 years ago

  • Parent task set to #7953

#9 Updated by intrigeri almost 5 years ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 50 to 100

#10 Updated by anonym almost 5 years ago

  • Status changed from Fix committed to Resolved

#11 Updated by intrigeri over 4 years ago

  • Blocks deleted (Feature #5288: Run the test suite automatically on autobuilt ISOs)

#12 Updated by intrigeri over 4 years ago

  • Parent task changed from #7953 to #8539

Also available in: Atom PDF