Project

General

Profile

Bug #7968

Tails OpenPGP Applet can't clearsign text including non-ASCII characters

Added by mercedes508 about 5 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
09/28/2014
Due date:
% Done:

100%

Feature Branch:
bugfix/7968-cant-clearsign-non-ascii-text
Type of work:
Code
Blueprint:
Starter:
Affected tool:
OpenPGP Applet

Description

When using gedit to type text including non-ASCII characters, and then using Tails OpenPGP Applet to clearsign it, the resulting text doesn't match with the original one, and thus the signature is bad.


Related issues

Blocks Tails - Feature #6507: Package our OpenPGP applet for Debian and maintain it there Resolved

Associated revisions

Revision 00fd45bf (diff)
Added by Tails developers about 5 years ago

Don't pass already encoded data to GTK2.

... Or it will be encoded twice. This fixes #7968 - "Tails OpenPGP
Applet can't clearsign text including non-ASCII characters". Only
affects clearsign, as PGP armored data is always ASCII.

Thanks to nodens for the patch!

History

#1 Updated by intrigeri about 5 years ago

  • Blocks Feature #6507: Package our OpenPGP applet for Debian and maintain it there added

#2 Updated by nodens about 5 years ago

  • Assignee set to nodens

#3 Updated by nodens about 5 years ago

  • Status changed from Confirmed to 11
  • Assignee deleted (nodens)
  • % Done changed from 0 to 60
  • QA Check set to Ready for QA
  • Type of work changed from Research to Code

Ok, figured that one out.

The data from gpg is encoded before being passed to the GTK2 clipboard, and GTK2 encodes it as well, so we end up with doubled-encoded data.

Doesn't affect anything other than clearsign, since everything else is armored. Also, the X primary clipboard is unaffected as well.

Fixed in bugfix/7968-cant-clearsign-non-ascii-text branch of the OpenPGP applet repository, I don't think I can commit to the main tail repo, so please get it there :
https://git-tails.immerda.ch/nodens/openpgp-applet/commit/?h=bugfix/7968-cant-clearsign-non-ascii-text

Cheers,

#4 Updated by nodens about 5 years ago

  • Assignee set to intrigeri

#5 Updated by nodens about 5 years ago

assigned to intrigeri since I'm not sure what the correct process should be until the applet has a proper debian package and Tails is using it... :)

#6 Updated by intrigeri about 5 years ago

  • Status changed from 11 to In Progress

#7 Updated by intrigeri about 5 years ago

  • Target version set to Tails_1.2.1

#8 Updated by sajolida about 5 years ago

  • Assignee deleted (intrigeri)
  • Target version changed from Tails_1.2.1 to Tails_1.3
  • Feature Branch set to bugfix/7968-cant-clearsign-non-ascii-text

Hi, the review and merge process is described here:

https://tails.boum.org/contribute/merge_policy/

According to this you should:

  • Assign this ticket to nobody. I did that for you.
  • Set the ticket's Target version. We already passed the freeze for 1.2.1 so this will go into 1.3 only, Done as well.
  • Ask for a review and merge on . I can't really do that for you.

#9 Updated by intrigeri about 5 years ago

  • Assignee set to intrigeri
  • Target version changed from Tails_1.3 to Tails_1.2.1

sajolida, thanks for your guidance and input. There are specifics to this ticket that make the general rules not necessarily applicable, though:

  • I've been reviewing nodens' work since he started working on this applet, and I have the problem space in mind, so it did make sense to assign it to me. (Also, given nodens' work is based on his own Git repo of the applet, which we don't use yet, and I think I'm the only one to ever have looked at, he had yet another good reason to assign this ticket to me :)
  • The freeze is about features, but generally bugfixes (assuming they're not too risky) are welcome. That's why I had set the target version to 1.2.1, and am reverting your change.

#10 Updated by nodens about 5 years ago

Just FYI : I did test the change on an old version of my applet far closer to the code Tails is using, on Squeeze and Wheezy virtual machines, so I'm pretty confident the fix will work in stable. I didn't test it in Tails, though.

#11 Updated by anonym about 5 years ago

  • Status changed from In Progress to 11
  • Assignee deleted (intrigeri)
  • % Done changed from 60 to 100
  • QA Check changed from Ready for QA to Pass

nodens wrote:

Just FYI : I did test the change on an old version of my applet far closer to the code Tails is using, on Squeeze and Wheezy virtual machines, so I'm pretty confident the fix will work in stable. I didn't test it in Tails, though.

I've tested the fix, and it works (i.e. the resulting clearsigns pasted via Ctrl+V are now OK, just like the middle-click-pasted ones). Merged (after fixing the indentation for the comment)! Thanks for the patch, nodens!

I some how failed to see that this ticket already was assigned to you, intrigeri, but I doubt that you'll be sad about me taking care of this.

#12 Updated by nodens about 5 years ago

Indentation fixed and branch merged in the nodens/openpgp-applet repo as well.

#13 Updated by BitingBird about 5 years ago

  • Status changed from 11 to Resolved

#14 Updated by nodens over 4 years ago

  • Blocks deleted (Feature #6507: Package our OpenPGP applet for Debian and maintain it there)

#15 Updated by intrigeri over 4 years ago

  • Blocks Feature #6507: Package our OpenPGP applet for Debian and maintain it there added

#16 Updated by intrigeri over 4 years ago

  • Affected tool set to OpenPGP Applet

Also available in: Atom PDF