Project

General

Profile

Bug #7966

Check if NM 0.9.10's "files are no longer watched for changes by default" change affects us

Added by intrigeri about 4 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
09/27/2014
Due date:
% Done:

100%

QA Check:
Feature Branch:
Type of work:
Test
Blueprint:
Starter:
Affected tool:

Description

See http://blogs.gnome.org/dcbw/2014/06/20/well-build-a-dream-house-of-net/. It might be that we need to run nmcli con reload after bind-mounting the NM config persistent directory, for example.

Hint: start with writing a test case to check that a connection added with NM persistence enabled shows up after rebooting with persistence enabled. We already have some code to add NM connections, that's used in the dhcp feature.

Associated revisions

Revision 2ac0870c (diff)
Added by intrigeri about 3 years ago

Draft a test to ensure that we can use a NetworkManager connection stored in persistence.

Will-fix: #7966

History

#1 Updated by kytv about 4 years ago

  • Assignee set to kytv

I'll take a stab at this as a way to delve into the automated tests.

#2 Updated by intrigeri about 4 years ago

kytv wrote:

I'll take a stab at this as a way to delve into the automated tests.

Cool. Any news?

#3 Updated by anonym about 4 years ago

I had to do the manual reloading when updating dhcp.feature, see d0da9fc.

#4 Updated by intrigeri about 3 years ago

intrigeri wrote:

kytv wrote:

I'll take a stab at this as a way to delve into the automated tests.

Cool. Any news?

Now that you're into automated tests, perhaps you want to release the lock on this ticket? Or else: ETA?

#5 Updated by intrigeri about 3 years ago

  • Assignee changed from kytv to intrigeri

(No reply from kytv, so I'm stealing this one.)

#6 Updated by intrigeri about 3 years ago

  • Status changed from Confirmed to In Progress

#7 Updated by intrigeri about 3 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 0 to 100

I could not run my draft test since the test suite is not functional enough on Jessie to go that far yet. In any case I think it's good to have an automated test for this, so I'll keep it around and will fix it later if needed (unless anonym is faster than me, which I would not mind :)

I tested this manually, and verified that we bind-mount the persistent NM connections directory before we start the NM service, so we're good here => closing.

Also available in: Atom PDF