Project

General

Profile

Bug #7951

Refactor code for task-specific browsers

Added by anonym about 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
09/26/2014
Due date:
% Done:

100%

Feature Branch:
bugfix/7951-refactor-chroot-browsers
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Browser

Description

The code in config/chroot_local-includes/usr/local/sbin/unsafe-browser should be refactored into a shell (or whatever) library. Code-sharing would be useful for the Unsage Browser and #7725 and other task-specific browsers (LAN browser?).


Related issues

Related to Tails - Feature #7725: Isolate I2P web browsing from Tor Resolved 08/02/2014
Related to Tails - Feature #7976: Disable LAN access in Tor Browser Resolved 11/05/2014
Blocks Tails - Feature #7419: Rename Tor Browser in camouflage mode? Rejected 06/19/2014

History

#1 Updated by anonym about 5 years ago

  • Subject changed from Refactor code for task-specific browa to Refactor code for task-specific browsers

#2 Updated by anonym about 5 years ago

  • Target version set to Tails_1.3

#3 Updated by intrigeri about 5 years ago

  • Related to Feature #7725: Isolate I2P web browsing from Tor added

#4 Updated by intrigeri about 5 years ago

  • Related to Feature #7976: Disable LAN access in Tor Browser added

#5 Updated by anonym about 5 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 30
  • Feature Branch set to bugfix/7951-refactor-chroot-browsers

I've pushed my WIP which refactores the low-hanging fruit. I'd like to refactor more of configure_chroot(), but since they differ so much I'm not sure if it will turn out to much benefit.

Also, this branch heavily optimizes the startup time and memory footprint of both browsers. A simple test of the Unsafe Browser showed a 50% reduction in startup time (from the verification prompt, until the browser window appears), both in separate, fresh Tails sessions so no cache is available.

#6 Updated by anonym about 5 years ago

  • Assignee deleted (anonym)
  • % Done changed from 30 to 50
  • QA Check set to Ready for QA

#7 Updated by intrigeri about 5 years ago

  • Assignee set to intrigeri

I'll take this one.

#8 Updated by intrigeri about 5 years ago

  • Assignee changed from intrigeri to anonym
  • QA Check changed from Ready for QA to Dev Needed

Initial code review sent to -dev@.

#9 Updated by anonym about 5 years ago

  • Assignee changed from anonym to intrigeri
  • % Done changed from 50 to 60
  • QA Check changed from Dev Needed to Ready for QA

#10 Updated by intrigeri about 5 years ago

anonym says:

For the record, an image built from this branch at commit d35dbc7 passes
all the features that directly use any of the chroot browsers:

  • features/firewall_leaks.feature
  • features/i2p.feature
  • features/unsafe_browser.feature

#11 Updated by intrigeri about 5 years ago

  • Blocks Feature #7419: Rename Tor Browser in camouflage mode? added

#12 Updated by intrigeri almost 5 years ago

  • Assignee changed from intrigeri to anonym
  • % Done changed from 60 to 70
  • QA Check changed from Ready for QA to Dev Needed

Almost there! see review on -dev@.

#13 Updated by intrigeri almost 5 years ago

  • Assignee changed from anonym to intrigeri
  • % Done changed from 70 to 80
  • QA Check changed from Dev Needed to Ready for QA

#14 Updated by intrigeri almost 5 years ago

  • Status changed from In Progress to 11
  • Assignee deleted (intrigeri)
  • % Done changed from 80 to 100
  • QA Check changed from Ready for QA to Pass

#15 Updated by BitingBird almost 5 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF