Project

General

Profile

Feature #7934

Upgrade to Tor 0.2.6.x

Added by intrigeri about 5 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
09/22/2014
Due date:
% Done:

100%

Feature Branch:
feature/8925-tor-0.2.6
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Subtasks

Feature #7935: Wait for Tor 0.2.6.x to be outResolved

Feature #8925: Test Tor 0.2.6.x in the context of TailsResolved

Feature #9147: Build Tor 0.2.6.6 with seccompResolved


Related issues

Blocks Tails - Bug #7283: Use upstream solution for Tor Launcher: Set ClientTransportPlugin according to the bridge entries Resolved 05/26/2014
Blocks Tails - Feature #9114: Investigate Tor Browser 4.5's new circuit lifetime behaviour Resolved 03/26/2015
Blocks Tails - Feature #7620: Drop Tor Launcher patch that relabels the finish button Resolved 07/19/2014
Blocks Tails - Feature #7087: Do not bundle Tor Launcher in the main Tails Git repository Resolved 04/15/2014
Blocks Tails - Feature #6840: Upstream our Tor Launcher changes Resolved 05/26/2014

Associated revisions

Revision e88f3b27
Added by intrigeri over 4 years ago

Merge remote-tracking branch 'origin/feature/8925-tor-0.2.6' into devel

Fix-committed: #7934, #9114, #7620, #7087, #7283, #6840

History

#1 Updated by intrigeri about 5 years ago

  • Blocks Bug #7283: Use upstream solution for Tor Launcher: Set ClientTransportPlugin according to the bridge entries added

#2 Updated by intrigeri almost 5 years ago

  • Feature Branch set to feature/8925-tor-0.2.6

#3 Updated by intrigeri over 4 years ago

  • Status changed from Confirmed to In Progress
  • Target version set to Tails_1.4

#4 Updated by anonym over 4 years ago

  • Assignee set to anonym

#5 Updated by anonym over 4 years ago

At the moment all tests using Tor bridges (tor_bridges.feature and the latter half of times_syncting.feauter) are broken because this branch makes us use the Tor Launcher bundled in the Tor Browser tarball. As of Tor Browser 4.0.6 (which is what Tails use since 1.3.2) that's Tor Launcher 0.2.7.0.2 but we use Tor Launcher 0.2.7.2 since Tails 1.3.2, which changes the order of the pages in the wizard, hence the problems with the tests.

There are two ways to fix this so this branch can be merged:

  • Temporarily reverting d899831 but then we'd have to revert that revert later, and live with a downgraded Tor Launcher.
  • We split out 3710b2c and fc6667a (into a feature/WXYZ-use-tor-browsers-bundled-tor-launcher branch) and restore the in-tree Tor Launcher 0.2.7.2 until the Tor Browser bundles it (or a higher version) and then we merge those commits back. For instance, once we merge feature/9031-tor-browser-4.5 this won't be a problem since it installs Tor Launcher 0.2.7.3.

#6 Updated by intrigeri over 4 years ago

anonym wrote:

As of Tor Browser 4.0.6 (which is what Tails use since 1.3.2) that's Tor Launcher 0.2.7.0.2 but we use Tor Launcher 0.2.7.2 since Tails 1.3.2, which changes the order of the pages in the wizard, hence the problems with the tests.

I'm confused. Introducing the new Tor Launcher was precisely meant to fix discrepancies between Tails and Tor Browser, in that wizard (#8964), and as a result we have other discrepancies, so it feels like we've made a mistake along the way. Anyway, no big deal :)

There are two ways to fix this so this branch can be merged:

  • Temporarily reverting d899831 but then we'd have to revert that revert later, and live with a downgraded Tor Launcher.

Kinda ugly, but acceptable.

  • We split out 3710b2c and fc6667a (into a feature/WXYZ-use-tor-browsers-bundled-tor-launcher branch) and restore the in-tree Tor Launcher 0.2.7.2 until the Tor Browser bundles it (or a higher version) and then we merge those commits back. For instance, once we merge feature/9031-tor-browser-4.5 this won't be a problem since it installs Tor Launcher 0.2.7.3.

If we go this way, we could move these two commits to feature/9031-tor-browser-4.5, then mark #9031 as blocked by #7934, then merge feature/8925-tor-0.2.6, then merge devel into feature/9031-tor-browser-4.5, right? Given we're almost ready to move to Tor 0.2.6, I think I prefer this solution.

#7 Updated by anonym over 4 years ago

  • Blocks Feature #9114: Investigate Tor Browser 4.5's new circuit lifetime behaviour added

#8 Updated by anonym over 4 years ago

  • Blocks Feature #7620: Drop Tor Launcher patch that relabels the finish button added

#9 Updated by anonym over 4 years ago

  • Blocks Feature #7087: Do not bundle Tor Launcher in the main Tails Git repository added

#10 Updated by anonym over 4 years ago

#11 Updated by anonym over 4 years ago

  • Assignee deleted (anonym)
  • QA Check set to Ready for QA

As stated in #9114, I've merged feature/9114-tor-with-bug15482.patch to feature/8925-tor-0.2.6. Please merge this branch! See the merge request on @tails-dev!

#12 Updated by intrigeri over 4 years ago

  • Assignee set to intrigeri

Code review passes, now going to run automated tests.

#13 Updated by intrigeri over 4 years ago

  • Status changed from In Progress to 11

#14 Updated by intrigeri over 4 years ago

  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

#15 Updated by BitingBird over 4 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF