Project

General

Profile

Bug #7904

Link to upgrade instructions in Tails Installer when a Tails USB stick is selected

Added by emmapeel about 4 years ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Installation
Target version:
Start date:
09/16/2014
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
bugfix/7904-15590-14849-14720-14810-installer-fixes-for-3.9, kurono/installer:bug/7904-change-link-upgrade-instructions
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Installer

Description

When opening the Tails installer, there is a documentation link pointing to the installation assistant.

But this link doesn't cover all options for the Tails installer, it just talks about upgrading the USB stick with Clone & Install.

So, we should consider providing a link for the upgrade options (Manual upgrade using Tails Installer).


Related issues

Related to Tails - Bug #5466: Link to documentation in Tails Installer does not open the documentation because it points to an old URL which is not properly redirected in Tails Resolved
Related to Tails - Feature #15392: Core work 2018Q2 → 2018Q3: User experience Confirmed 03/09/2018

Associated revisions

Revision eb8939e2 (diff)
Added by intrigeri 4 months ago

Enable the bugfix-7904-15590-14849-14720-14810-installer-fixes-for-3.9 APT overlay (refs: #7904).

History

#1 Updated by BitingBird almost 4 years ago

  • Affected tool set to Installer

#2 Updated by xin over 1 year ago

  • Related to Bug #5466: Link to documentation in Tails Installer does not open the documentation because it points to an old URL which is not properly redirected in Tails added

#3 Updated by u over 1 year ago

  • Subject changed from Tails Installer interface links to installing and not to upgrading. to Consider providing a link to upgrade instructions in tails-installer UI

#4 Updated by u over 1 year ago

  • Description updated (diff)
  • Assignee set to sajolida

I think this is a UX related proposal, assigning to sajolida.

#5 Updated by u over 1 year ago

  • Type of work changed from Code to User interface design

#6 Updated by sajolida over 1 year ago

#7 Updated by sajolida about 1 year ago

#8 Updated by sajolida about 1 year ago

  • Blocks Feature #14761: Core work 2017Q4 → 2018Q1: User experience added

#9 Updated by sajolida 8 months ago

  • Blocks deleted (Feature #14761: Core work 2017Q4 → 2018Q1: User experience)

#10 Updated by sajolida 8 months ago

  • Assignee changed from sajolida to kurono
  • Type of work changed from User interface design to Code

Now that we have #9005 we should replace the link "Installation Instructions" with a link to "Manual Upgrade Instructions" when a Tails USB stick is selected.

kurono: Are you interested in working on this?

#11 Updated by sajolida 8 months ago

  • Subject changed from Consider providing a link to upgrade instructions in tails-installer UI to Link to upgrade instructions in Tails Installer when a Tails USB stick is selected

#12 Updated by kurono 5 months ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from kurono to sajolida
  • Target version set to Tails_3.8
  • % Done changed from 0 to 10
  • QA Check set to Ready for QA
  • Feature Branch set to bug/7904-change-link-upgrade-instructions

#13 Updated by intrigeri 5 months ago

  • Target version changed from Tails_3.8 to Tails_3.9

#14 Updated by sajolida 4 months ago

  • Related to Feature #15392: Core work 2018Q2 → 2018Q3: User experience added

#15 Updated by sajolida 4 months ago

  • Assignee changed from sajolida to kurono
  • QA Check changed from Ready for QA to Info Needed

Hey, sorry for the delay!

I like what I can understand from 07bca4da but I couldn't test it because I'm not sure about your Git history...

When I do:

git log --pretty=oneline origin/master..kurono/bug/7904-change-link-upgrade-instructions

I get 589 commits of difference between origin and your branch.

Can you double-check your Git history?

Then you can probably reassign it to intrigeri to see if he can find a reviewer for the code.

#16 Updated by kurono 4 months ago

  • Assignee changed from kurono to intrigeri
  • % Done changed from 10 to 20
  • QA Check changed from Info Needed to Ready for QA

sajolida wrote:

Hey, sorry for the delay!

I like what I can understand from 07bca4da but I couldn't test it because I'm not sure about your Git history...

When I do:

[...]

I get 589 commits of difference between origin and your branch.

Can you double-check your Git history?

Then you can probably reassign it to intrigeri to see if he can find a reviewer for the code.

Ah yeah my master branch was mixed, I have fixed the problem.

#17 Updated by intrigeri 4 months ago

  • Assignee changed from intrigeri to kurono
  • % Done changed from 20 to 50
  • QA Check changed from Ready for QA to Dev Needed
  • Feature Branch changed from bug/7904-change-link-upgrade-instructions to kurono/installer:bug/7904-change-link-upgrade-instructions

Code review passes but I'd rather see help_install_link renamed to help_link, to better express what it is about. What do you think?

#18 Updated by kurono 4 months ago

  • Assignee changed from kurono to intrigeri
  • QA Check changed from Dev Needed to Ready for QA

intrigeri wrote:

Code review passes but I'd rather see help_install_link renamed to help_link, to better express what it is about. What do you think?

I agree, I have made the renaming.

#19 Updated by intrigeri 4 months ago

  • Assignee changed from intrigeri to kurono
  • QA Check changed from Ready for QA to Dev Needed

help_install_link is still used in data/tails-installer.ui.

#20 Updated by kurono 4 months ago

  • Assignee changed from kurono to intrigeri
  • QA Check changed from Dev Needed to Ready for QA

intrigeri wrote:

help_install_link is still used in data/tails-installer.ui.

ups, I have fixed that.

#21 Updated by intrigeri 4 months ago

  • Feature Branch changed from kurono/installer:bug/7904-change-link-upgrade-instructions to bugfix/7904-15590-14849-14720-14810-installer-fixes-for-3.9, kurono/installer:bug/7904-change-link-upgrade-instructions

#22 Updated by intrigeri 4 months ago

  • % Done changed from 50 to 60

Code review passes. Built + uploaded a package, let's see what Jenkins thinks.

#23 Updated by intrigeri 4 months ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (intrigeri)
  • % Done changed from 60 to 100
  • QA Check changed from Ready for QA to Pass

Jenkins is happy, tested manually => merged!

#24 Updated by intrigeri 4 months ago

  • Status changed from Fix committed to In Progress

#25 Updated by intrigeri 4 months ago

  • Status changed from In Progress to Fix committed

#26 Updated by intrigeri 2 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF