Project

General

Profile

Bug #7889

Update install doc with syslinux-utils

Added by BitingBird over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Installation
Target version:
-
Start date:
09/11/2014
Due date:
% Done:

0%

Feature Branch:
Type of work:
End-user documentation
Blueprint:
Starter:
Yes
Affected tool:

Description

Hi! Seems like the syslinux package was divided and the "isohybrid" command now comes from syslinux-utils. Please update https://tails.boum.org/doc/first_steps/installation/manual/linux/index.en.html to say "install syslinux-utils" and "sudo apt-get install syslinux-utils".

Setting elevated and next version, because it's a regression that makes our install doc not working.


Related issues

Related to Tails - Bug #8155: No isohybrid shipped in Tails anymore Resolved 10/18/2014
Duplicated by Tails - Bug #7761: isohybrid has moved in syslinux-utils package on Jessie Duplicate

History

#1 Updated by BitingBird over 5 years ago

Well, maybe the package was not divided and syslinux-utils simply replaces syslinux. (Breaks: syslinux (< 3:6.00~pre4+dfsg-5~), syslinux-common (< 3:6.00~pre4+dfsg-5~) Replaces: syslinux, syslinux-common). The install instructions should say syslinux-utils in any case :)

#2 Updated by BitingBird over 5 years ago

... except this change is for jessie. stable still needs syslinux I think.

#3 Updated by sajolida over 5 years ago

  • Type of work changed from Documentation to Research

I think that this is only true starting from Jessie.

Could you also make sure to which versions of Ubuntu this applies?

Then we should add something to the doc telling people to install syslinux-utils if they are on Debian Jessie or Ubuntu XXX.

#4 Updated by BitingBird over 5 years ago

https://mailman.boum.org/pipermail/tails-dev/2014-September/006882.html

dkg proposed a patch on the mailing-list, adding jessie (but not ubuntu).

Searching launchpad, they seem to have nearly the same syslinux version as Jessie in "The Utopic Unicorn" (3:6.03~pre18+dfsg-1 in Ubuntu, 3:6.03~pre20+dfsg-3 in Jessie), and syslinux-utils seems to be included in the syslinux package - I don't really understand which one you're supposed to install.

https://launchpad.net/ubuntu/+source/syslinux is

#6 Updated by intrigeri over 5 years ago

  • Status changed from Confirmed to Resolved
  • Type of work changed from Research to Documentation

Fix with commit dd22262.

#7 Updated by intrigeri over 5 years ago

  • Duplicated by Bug #7761: isohybrid has moved in syslinux-utils package on Jessie added

#8 Updated by mercedes508 over 5 years ago

  • Status changed from Resolved to Confirmed
  • Target version changed from Tails_1.2 to Tails_1.2.1

Actually in Tails 1.2, syslinux-utils needs to be installed in order to do isohybrid as well, even if syslinux is installed.

This should be written in the doc.

#9 Updated by intrigeri over 5 years ago

  • Status changed from Confirmed to Resolved
  • Target version deleted (Tails_1.2.1)

Well, that's not a doc issue, but a regression in Tails => #8155.

#10 Updated by intrigeri over 5 years ago

  • Related to Bug #8155: No isohybrid shipped in Tails anymore added

Also available in: Atom PDF