Project

General

Profile

Feature #7823

Feature #6298: Write more automated tests

Finish automating the Unsafe Browser test suite

Added by intrigeri over 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
Start date:
08/26/2014
Due date:
% Done:

100%

Feature Branch:
test/7823-unsafe-browser
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Unsafe Browser

Associated revisions

Revision ad892d22 (diff)
Added by Tails developers almost 5 years ago

Remove manual tests for the Unsafe Browser (Will-fix: #7823).

These have now been automated!

Revision ec2299f6
Added by Tails developers almost 5 years ago

Merge remote-tracking branch 'origin/test/7823-unsafe-browser' into devel

Fix-committed: #7823.

History

#4 Updated by anonym about 5 years ago

  • Target version changed from Tails_1.2.2 to Tails_1.2.3

#5 Updated by BitingBird about 5 years ago

  • Affected tool set to Unsafe Browser

#6 Updated by anonym about 5 years ago

  • Target version changed from Tails_1.2.3 to Tails_1.3

#7 Updated by Tails almost 5 years ago

  • Status changed from Confirmed to In Progress

Applied in changeset commit:02cd3e945e6393233bc2d09e7b979a3941cec7b0.

#8 Updated by anonym almost 5 years ago

  • Assignee changed from anonym to kytv
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA
  • Feature Branch set to test/7823-unsafe-browser

#9 Updated by kytv almost 5 years ago

  • Assignee deleted (kytv)
  • % Done changed from 50 to 90
  • QA Check changed from Ready for QA to Pass

Changes look good, runs successfully (when not hitting #8686), and tests what it's supposed to test.

+1 on merging. :)

#10 Updated by intrigeri almost 5 years ago

  • Assignee set to intrigeri

#11 Updated by intrigeri almost 5 years ago

  • Assignee changed from intrigeri to anonym
  • QA Check changed from Pass to Info Needed

I'm fine with merging this branch up to, and including, commit:02cd3e945e6393233bc2d09e7b979a3941cec7b0. But I don't understand how the two next commits on that branch are related.

#12 Updated by anonym almost 5 years ago

  • Assignee changed from anonym to intrigeri
  • QA Check changed from Info Needed to Ready for QA

intrigeri wrote:

I'm fine with merging this branch up to, and including, commit:02cd3e945e6393233bc2d09e7b979a3941cec7b0. But I don't understand how the two next commits on that branch are related.

I should have explained its inclusion better. It's a pretty damn usable script when developing and debugging tests. Example: let's say I've added some @vm.execute(cmd) but something was wrong with cmd so the test fails. Since I ran the test suite with --pause-on-fail the VM and its remote shell are still running. I can then use the vm-execute to revise cmd without having to restart the whole test, which takes time. Also, if a test fails and I want to inquire what went wrong I often find running some command via the remote shell much more convenient than starting virt-viewer and then start GNOME Terminal (and generally we'll be without root access then, unlike with the remote shell).

I could put those commits in a separate branch, if you so prefer.

#13 Updated by intrigeri almost 5 years ago

I should have explained its inclusion better. It's a pretty damn usable script when developing and debugging tests.

OK, cool. And it does work with that hard-coded 1337 remote shell port?
Or does it need manual tweaking?

I could put those commits in a separate branch, if you so prefer.

Let's try to merge it at the same time, first. If the questions I'm asking above result in "needs more dev", then yes please.

#14 Updated by intrigeri almost 5 years ago

  • Assignee changed from intrigeri to anonym
  • QA Check changed from Ready for QA to Info Needed

#15 Updated by anonym almost 5 years ago

  • Assignee changed from anonym to intrigeri
  • QA Check changed from Info Needed to Ready for QA

intrigeri wrote:

I should have explained its inclusion better. It's a pretty damn usable script when developing and debugging tests.

OK, cool. And it does work with that hard-coded 1337 remote shell port?

Yes, it's hardcoded inside the test suite too (features/domains/default.xml).

Or does it need manual tweaking?

No tweaking needed.

I could put those commits in a separate branch, if you so prefer.

Let's try to merge it at the same time, first. If the questions I'm asking above result in "needs more dev", then yes please.

Merge!

#16 Updated by Tails almost 5 years ago

  • Status changed from In Progress to 11
  • % Done changed from 90 to 100

Applied in changeset commit:676127b0cd939b5443a6849b57128729b71276e1.

#17 Updated by intrigeri almost 5 years ago

  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

#18 Updated by BitingBird almost 5 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF