Project

General

Profile

Feature #7798

Support more Broadcom Wi-Fi chipsets

Added by mercedes508 over 4 years ago. Updated 11 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Hardware support
Target version:
-
Start date:
08/19/2014
Due date:
% Done:

0%

QA Check:
Info Needed
Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

In order to spport more Broadcom Wi-Fi chipset, broadcom-sta-dkms is currently needed. However, that driver contains a binary-only, proprietary part, so it's not really an option. Besides, it's buggy with some hardware models wrt. MAC spoofing. Our only hope thus seems to be that someone writes a free software driver, which may first require Broadcom to release specifications.


Related issues

Related to Tails - Bug #8662: Network device is not detected on MacBook Pro with retina display 2014 Rejected 01/09/2015
Related to Tails - Bug #9928: Add MacBookPro11,5 to Broadcom known issues Rejected 08/06/2015
Related to Tails - Bug #9930: Create a Broadcom network adapters section on the known issues page Resolved 08/06/2015
Duplicated by Tails - Feature #7971: Broadcom BCM43xx/AirPort Extreme support in Tails Duplicate 09/29/2014

Associated revisions

Revision be05f9af (diff)
Added by intrigeri over 3 years ago

Don't install the broadcom-sta (aka. 'wl') kernel module.

Its "source code" contains a binary object meant to be loaded into the kernel.
We have good reasons to ship binary firmware blobs, but going as far as shipping
binary kernel modules is something different: we have never crossed that line
yet, and IMO we should not.

This reverts commits 6024ec9795e683118dde8f18165cf64a660ec44f,
b5c40c35b7b525a3eee1977625a830f5f40075b9,
b51a4edd4aff6723877ce28ae3e8a0270d7c6395 and
35757e7c568436015ce867fe112b41b4552d091e.

Refs: #7798

History

#1 Updated by intrigeri over 4 years ago

  • Tracker changed from Bug to Feature
  • Subject changed from Support more broadcom Wi-Fi chipset to Support more Broadcom Wi-Fi chipsets
  • Status changed from New to Confirmed
  • Type of work changed from Code to Debian

As discussed a few times on tails-dev@ recently:

  1. no, we can't simply add broadcom-sta-dkms, it would break things for some chipsets we already support;
  2. the right way to solve this is auto-detection at boot time, which is WIP in live-config

#2 Updated by emmapeel over 4 years ago

Today other user reported

02:00.0 Network controller [0280]: Broadcom Corporation BCM43228 802.11a/b/g/n

Not working. Maybe we can add it to the known issues along with the workaround?

#3 Updated by intrigeri about 4 years ago

  • Type of work changed from Debian to Code

The needed bits are in now in Debian:

#4 Updated by intrigeri about 4 years ago

  • Duplicated by Feature #7971: Broadcom BCM43xx/AirPort Extreme support in Tails added

#5 Updated by intrigeri about 4 years ago

Note that live-config 4.x seems to be working just fine in our Jessie-based experimental images, so perhaps it would work too on Wheezy.

#6 Updated by intrigeri almost 4 years ago

  • Status changed from Confirmed to In Progress
  • Target version set to Tails_2.0
  • % Done changed from 0 to 30
  • Feature Branch set to feature/jessie

Seems to work, but I lack the hardware to actually test it for real => sent a call for testing on -testers@.

#7 Updated by intrigeri almost 4 years ago

  • Assignee set to intrigeri

#8 Updated by intrigeri almost 4 years ago

  • Related to Bug #8662: Network device is not detected on MacBook Pro with retina display 2014 added

#9 Updated by sajolida almost 4 years ago

I've been reported that the Broadcom from MacBook Pro (Retina, 15-inch, Early 2013) is working perfectly on Tails Jessie. Good news!

#10 Updated by intrigeri almost 4 years ago

I've been reported that the Broadcom from MacBook Pro (Retina, 15-inch, Early 2013) is working perfectly on Tails Jessie. Good news!

Yeah, but the changes that fix that apparently break support for other chipsets, see the discussion on tails-support@ :/

#11 Updated by intrigeri over 3 years ago

  • Status changed from In Progress to Confirmed
  • Assignee deleted (intrigeri)
  • Target version deleted (Tails_2.0)
  • % Done changed from 30 to 0

Reverted in be05f9af since that driver contains a binary-only, proprietary part.

#12 Updated by tsammut over 3 years ago

If it helps, TAILS does not appear to detect the wireless adapter in my 15" macbook pro 11,5. Here is some output from my everyday OS:

$ sudo dmesg | grep MacBookPro
[ 0.000000] DMI: Apple Inc. MacBookPro11,5/Mac-06F11F11946D27C5, BIOS MBP114.88Z.0172.B00.1503301047 03/30/2015
$

$ sudo lspci vs 04:00.0
04:00.0 Network controller: Broadcom Corporation BCM43602 802.11ac Wireless LAN SoC (rev 01)
Subsystem: Apple Inc. Device 0152
Flags: bus master, fast devsel, latency 0, IRQ 31
Memory at b0800000 (64-bit, non-prefetchable) [size=32K]
Memory at b0400000 (64-bit, non-prefetchable) [size=4M]
Capabilities: [48] Power Management version 3
Capabilities: [58] MSI: Enable+ Count=1/16 Maskable
64bit+
Capabilities: [68] Vendor Specific Information: Len=44
Capabilities: [ac] Express Endpoint, MSI 00
Capabilities: [100] Advanced Error Reporting
Capabilities: [13c] Device Serial Number 1d-11-60-ff-ff-ee-a4-5e
Capabilities: [150] Power Budgeting
Capabilities: [160] Virtual Channel
Capabilities: [1b0] Latency Tolerance Reporting
Capabilities: [220] #15
Capabilities: [240] #1e
Kernel driver in use: brcmfmac
Kernel modules: brcmfmac

$

Thank you for working on TAILS.

#13 Updated by intrigeri over 3 years ago

  • Feature Branch deleted (feature/jessie)

#14 Updated by BitingBird over 3 years ago

  • Related to Bug #9928: Add MacBookPro11,5 to Broadcom known issues added

#15 Updated by intrigeri over 3 years ago

  • Description updated (diff)

#16 Updated by intrigeri over 3 years ago

  • Related to Bug #9930: Create a Broadcom network adapters section on the known issues page added

#17 Updated by u 11 months ago

  • Assignee set to mercedes508
  • QA Check set to Info Needed

@mercedes: is this still needed in your opinion?

#18 Updated by mercedes508 11 months ago

  • Status changed from Confirmed to Rejected

Closing as there's nothing else we can do I guess.

Also available in: Atom PDF