Project

General

Profile

Feature #7790

Bug #7423: Have what we need included in Debian Jessie

Feature #5875: Make sure all the Python 3 libraries we need are in Jessie

Package Isis' python-gnupg

Added by alant about 5 years ago. Updated about 5 years ago.

Status:
Rejected
Priority:
High
Assignee:
-
Category:
-
Target version:
-
Start date:
08/16/2014
Due date:
% Done:

0%

Feature Branch:
Type of work:
Debian
Blueprint:
Starter:
Affected tool:

Description

Tails Greeter uses GnuPGInterface whose not maintained anymore. We should replace it with Isis's fork of python-gnupg (ITP).

History

#1 Updated by intrigeri about 5 years ago

  • Description updated (diff)

#2 Updated by intrigeri about 5 years ago

  • Subject changed from Package python3-gnupg to Package Isis' python-gnupg
  • Assignee set to alant
  • QA Check set to Info Needed

I do hope that Isis' forks lands into the Debian archive some day, but in the meantime, why isn't the python3-gnupg package (upstream, already in Wheezy and Jessie) good enough for our needs?

#3 Updated by alant about 5 years ago

why isn't the python3-gnupg package (upstream, already in Wheezy and Jessie) good enough for our needs?

If I remember well, it used to lack using a custom keyring (self.options.extra_args = ["--keyring", keyring, "--no-default-keyring"] in whisperBack/encryption.py) but official documentation state it's possible using the keyring keyword at class instanciation (http://pythonhosted.org//python-gnupg/#getting-started).

So there seems me to be no reason it wouldn't be good enough.

#4 Updated by alant about 5 years ago

  • Status changed from New to Rejected
  • Assignee deleted (alant)
  • QA Check deleted (Info Needed)

Also available in: Atom PDF