Project

General

Profile

Bug #7769

Bug #7688: DHCP client leaks hostname "amnesia"

Resets hostname to the one provided by the DHCP server

Added by intrigeri about 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
-
Target version:
-
Start date:
08/10/2014
Due date:
% Done:

100%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Description

I've seen (once, for now) a Tails ISO built from current experimental have its hostname reset to the one provided by the DHCP server:

$ hostname
whatever

We don't try that hard to avoid leaking the hostname, so this is an important issue.

Associated revisions

Revision e105bbcd (diff)
Added by Tails developers about 5 years ago

Override the hostname provided by the DHCP server (Closes: #7769).

History

#1 Updated by intrigeri about 5 years ago

  • Assignee set to intrigeri

I'll try to have a closer look in the next few days. Feel free to steal it from me; if doing so, make sure you reassign the ticket to you so that we don't duplicate work.

#2 Updated by intrigeri about 5 years ago

  • Related to Bug #7688: DHCP client leaks hostname "amnesia" added

#3 Updated by intrigeri about 5 years ago

  • Related to deleted (Bug #7688: DHCP client leaks hostname "amnesia")

#4 Updated by intrigeri about 5 years ago

  • Status changed from New to Resolved
  • Priority changed from Elevated to High
  • % Done changed from 0 to 100
  • Parent task set to #7688

Indeed, this was caused by the changes introduced to fix #7688, and is now resolved in the corresponding branch with commit 4b007f8c.

Also available in: Atom PDF