Project

General

Profile

Bug #7768

Tails Installer not correctly localized

Added by BitingBird over 5 years ago. Updated about 2 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Internationalization
Target version:
Start date:
08/09/2014
Due date:
% Done:

0%

Feature Branch:
Type of work:
Test
Blueprint:
Starter:
Affected tool:
Installer

Description

The warning message in frensh is translated, but the buttons are "No/Yes".

Bildschirmfoto von »2017-09-06 15-58-58«.png View (137 KB) u, 09/06/2017 02:04 PM

Bildschirmfoto von »2017-09-06 16-00-16«.png View (69.4 KB) u, 09/06/2017 02:04 PM


Related issues

Related to Tails - Feature #6488: Make Tails Installer's .desktop-file translatable in Transifex Confirmed 12/11/2013
Related to Tails - Bug #12588: Translations of the Installer are not applied Resolved 05/24/2017

History

#1 Updated by intrigeri over 5 years ago

  • Type of work changed from Translate to Code

The "Yes" string is not in the PO files, so likely we're missing the Qt base translations package, or something.

#2 Updated by BitingBird almost 5 years ago

  • Affected tool set to Installer

#4 Updated by BitingBird over 4 years ago

  • Subject changed from Installer translation: clone and upgrade to Have Qt base translation package in Tails

renaming now that the problem is clearer :)

#5 Updated by intrigeri over 4 years ago

I think that's https://packages.qa.debian.org/q/qttranslations-opensource-src.html

Nope, that package is for Qt5 and Tails Installer is currently using Qt4.

#6 Updated by intrigeri over 4 years ago

Subject changed from Installer translation: clone and upgrade to Have Qt base translation package in Tails

renaming now that the problem is clearer :)

Oh, IMO you're overestimating my guess. I don't think that renaming this ticket (whose title described a known issue very clearly), to give it a title that merely expresses what I guessed might be a solution, is an improvement. Going to revert this change.

#7 Updated by intrigeri over 4 years ago

  • Subject changed from Have Qt base translation package in Tails to Yes/No buttons are not localized in Tails Installer

#8 Updated by u over 2 years ago

  • Subject changed from Yes/No buttons are not localized in Tails Installer to Tails Installer not correctly localized

Testing in Tails 3.0:

The only button which is localized is "Install Tails". Everything else is in english.

#9 Updated by u over 2 years ago

  • Related to Feature #6488: Make Tails Installer's .desktop-file translatable in Transifex added

#10 Updated by intrigeri over 2 years ago

  • Related to Bug #12588: Translations of the Installer are not applied added

#11 Updated by intrigeri over 2 years ago

  • Assignee set to u
  • QA Check set to Info Needed

In French, much more is translated. What language did you test with?

I think the root cause was fixed in #12588 on the code side, and by talking to Colin on the Transifex side. But this happened really close to the 3.0 release, so I wouldn't be surprised if most languages had incomplete translations in Tails 3.0.

#12 Updated by u over 2 years ago

  • QA Check deleted (Info Needed)
  • Type of work changed from Code to Test

intrigeri wrote:

In French, much more is translated. What language did you test with?

I tested in German.

I think the root cause was fixed in #12588 on the code side, and by talking to Colin on the Transifex side. But this happened really close to the 3.0 release, so I wouldn't be surprised if most languages had incomplete translations in Tails 3.0.

Then I'll wait until the next release to check this again.

#13 Updated by u over 2 years ago

  • Target version set to Tails_3.0.1

#14 Updated by intrigeri over 2 years ago

  • Target version changed from Tails_3.0.1 to Tails_3.1

You wrote "Then I'll wait until the next release to check this again" so I guess you will test this after 3.0.1 is out, which can't be a blocker for the 3.0.1 release :)

#15 Updated by u over 2 years ago

  • Target version changed from Tails_3.1 to Tails_3.2

#16 Updated by u over 2 years ago

In Tails 3.1 the installer GUI is still in english. Only one button is translated in the second screen of the installer. Any idea what this is due to? See screenshots.

#17 Updated by u over 2 years ago

#18 Updated by anonym about 2 years ago

  • Assignee changed from anonym to u

I looked in po/de.po, and most strings are not translated, or are fuzzy, so I think this makes sense. It works well for other languages I tried, with better translation coverage (e.g. French).

#19 Updated by u about 2 years ago

  • Status changed from Confirmed to Rejected

Ok, rejecting this ticket.

#20 Updated by anonym about 2 years ago

  • Target version changed from Tails_3.2 to Tails_3.3

#21 Updated by anonym about 2 years ago

  • Target version changed from Tails_3.3 to Tails_3.2

Also available in: Atom PDF