Project

General

Profile

Feature #7746

Feature #5663: Return to Icedove

Feature #6148: Torbirdy in Debian

Feature #6154: Secure the Icedove autoconfig wizard

Rebase our patches on top of Icedove 38

Added by intrigeri almost 5 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
08/05/2014
Due date:
% Done:

100%

Feature Branch:
icedove:tails-secure_account_creation-38.6.0
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Email Client

Related issues

Duplicated by Tails - Feature #9492: Adapt the patchset to work on current Icedove Duplicate 05/29/2015
Blocks Tails - Feature #6369: Build Debian packages of Icedove 38 with our patches / create proper branch situation Resolved 10/16/2013
Blocked by Tails - Feature #7064: Update our plans for securing Icedove's autoconfig wizard wrt. recent developments Resolved

History

#1 Updated by intrigeri almost 5 years ago

  • Blocks Feature #6369: Build Debian packages of Icedove 38 with our patches / create proper branch situation added

#2 Updated by intrigeri almost 5 years ago

  • Blocks deleted (Feature #6369: Build Debian packages of Icedove 38 with our patches / create proper branch situation)

#3 Updated by intrigeri almost 5 years ago

  • Target version deleted (Sustainability_M1)

#4 Updated by intrigeri almost 5 years ago

  • Parent task changed from #5663 to #6154

#5 Updated by intrigeri almost 5 years ago

  • Blocks Feature #6369: Build Debian packages of Icedove 38 with our patches / create proper branch situation added

#6 Updated by intrigeri almost 5 years ago

  • Blocked by Feature #7064: Update our plans for securing Icedove's autoconfig wizard wrt. recent developments added

#7 Updated by intrigeri almost 5 years ago

  • Category set to 212

#8 Updated by anonym over 4 years ago

  • Feature Branch set to icedove:secure_account_creation-31.3.0-1_deb7u1

It seems I have rebased the patches on version 31.3.0-1_deb7u1 in the secure_account_creation-31.3.0-1_deb7u1 branch. I can't recall if I have tested that it actually works. The other branches in our Git repo that contains some version of the patches are:

  • secure_account_creation (based on version 8.0-1)
  • secure_account_creation-24 (based on version 24.6.0-1~deb7u1)

#9 Updated by intrigeri about 4 years ago

  • Subject changed from Rebase our patches on top of Icedove 31 to Rebase our patches on top of Icedove 38
  • Assignee set to u
  • Target version set to 246

Icedove 38 will be out soon, so before the work on Icedove actually starts.

#11 Updated by sajolida over 3 years ago

  • Target version changed from 246 to Tails_2.0

#12 Updated by u over 3 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • Feature Branch changed from icedove:secure_account_creation-31.3.0-1_deb7u1 to icedove:tails_secure_account_creation-38.5.0

anonym has rebased the patches on icedove:secure_account_creation-38.5.0-1. However this branch actually seems to not have the latest packaging work, but only the latest upstream code.

I've also retested these patches on a clean checkout of the upstream code, version 38.5.0. I did that using Debian's git repository branch upstream/38.5.0. They do apply cleanly.

From here, I am treating these patches as debian patches only. I have rebased them on a branch forked off of Debian's master branch, which is the current packaging branch. There, I've added them to debian/patches and debian/patches/series. I'll push this branch to our Icedove repository. This shall be icedove:tails_secure_account_creation-38.5.0. I will propose this as a patch against the Debian package for the time being.

#13 Updated by u over 3 years ago

  • Feature Branch changed from icedove:tails_secure_account_creation-38.5.0 to icedove:tails-secure_account_creation-38.5.0

#14 Updated by intrigeri over 3 years ago

JFTR, "gbp pq" (and similar tools) allows one to maintain patches against upstream code "the Git way", which is generally a nice way to work on the code and patches themselves, and still get them as quilt patches, that we need for the Debian packaging.

#15 Updated by u over 3 years ago

  • Target version changed from Tails_2.0 to Tails_2.2

#16 Updated by u over 3 years ago

intrigeri wrote:

JFTR, "gbp pq" (and similar tools) allows one to maintain patches against upstream code "the Git way", which is generally a nice way to work on the code and patches themselves, and still get them as quilt patches, that we need for the Debian packaging.

Indeed, but from what I understand this creates another branch (quite heavy on this code), and so I stick to the debian quilt way for now.

#18 Updated by anonym over 3 years ago

u wrote:

I've finally managed to push this to https://git-tails.immerda.ch/icedove/log/?h=tails_secure_account_creation-38.5.0

I created a new branch tails_secure_account_creation-38.6.0-deb8u1 which is a rebase of this branch ontop of the Debian upstream's security/jessie and built packages (see #6158#note-22).

Of course, I guess we should do it cleanly some how, with a tails_secure_account_creation-38.6.0 branch based on Debian unstable, etc.

#19 Updated by u over 3 years ago

  • Status changed from In Progress to Resolved
  • Feature Branch changed from icedove:tails-secure_account_creation-38.5.0 to icedove:tails-secure_account_creation-38.6.0

#20 Updated by intrigeri about 3 years ago

  • Assignee deleted (u)
  • % Done changed from 10 to 100

#21 Updated by intrigeri about 3 years ago

  • Duplicated by Feature #9492: Adapt the patchset to work on current Icedove added

Also available in: Atom PDF