Project

General

Profile

Feature #7707

Feature #7705: Better compress the SquashFS

Better compress the IUK's SquashFS

Added by intrigeri over 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
07/31/2014
Due date:
% Done:

100%

Feature Branch:
iuk:feature/7707-better-compress-squashfs-in-iuks
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Upgrader

History

#1 Updated by intrigeri over 5 years ago

  • Feature Branch set to feature/7707-better-compress-squashfs-in-iuksiuk:

#2 Updated by intrigeri over 5 years ago

  • % Done changed from 0 to 50

Implemented. 9.3% of decrease in size, 120% of increase in build time. Seems worth it. I'll file a pull request once I have tested that the resulting IUK can be successfully installed, and that the operation produces a bootable Tails.

#3 Updated by intrigeri over 5 years ago

  • Status changed from Confirmed to In Progress

#4 Updated by intrigeri over 5 years ago

  • Feature Branch changed from feature/7707-better-compress-squashfs-in-iuksiuk: to iuk:feature/7707-better-compress-squashfs-in-iuks

#5 Updated by intrigeri over 5 years ago

  • Assignee deleted (intrigeri)
  • QA Check set to Ready for QA

intrigeri wrote:

I'll file a pull request once I have tested that the resulting IUK can be successfully installed, and that the operation produces a bootable Tails.

Works for me.

#6 Updated by anonym about 5 years ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

I see a 7% decrease in size for the 1.1.1_to_1.1.2 IUK. The upgrade from 1.1.1 to 1.1.2 works fine. Merged!

#7 Updated by anonym about 5 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF