Project

General

Profile

Bug #7654

Tails Installer crashes if any UUID includes Unicode character

Added by sajolida about 5 years ago. Updated about 1 year ago.

Status:
Confirmed
Priority:
Normal
Assignee:
-
Category:
Installation
Target version:
-
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
No
Affected tool:
Installer

Description

Someone reported us that Tails Installer crashes if any UUID on the
system includes a Unicode character. Apparently, this could happen with
some disk encryption software for Windows. Then, even if that UUID is on
the local hard disk, Tails Installer crashes:

amnesia@amnesia:~$ liveusb-creator -u -n --clone -P -m -x -v
Bus::open: Can not get ibus-daemon's address.
IBusInputContext::createInputContext: no connection to ibus-daemon
[creator:1188] extlinux not found! Only FAT filesystems will be
supported
[creator:663] Skipping device '/org/freedesktop/UDisks/devices/sda1'
connected to 'ata' interface
Traceback (most recent call last):
File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line
604, in msg_reply_handler
reply_handler(*message.get_args_list(**get_args_opts))
File "/usr/lib/python2.7/dist-packages/liveusb/creator.py", line
647, in handle_reply
'uuid': str(dev.Get(device, 'IdUuid')),
UnicodeEncodeError: 'ascii' codec can't encode character u'\u0297' in
position 18: ordinal not in range(128)

The reporter says that this can be solved by changing str() to unicode()
on line 647 of creator.py.

Someone knowledgeable about the internals of the installer should
investigate whether this fix could be applied with no risk.


Related issues

Related to Tails - Feature #15292: Distribute a USB image Resolved 04/14/2016 01/29/2019

History

#1 Updated by BitingBird about 5 years ago

  • Category set to Installation
  • Starter set to No

#2 Updated by intrigeri almost 5 years ago

  • Blocked by Bug #8331: Merge liveusb-creator upstream changes added

#3 Updated by intrigeri almost 5 years ago

Upstream has supposedly fixed all such bugs recently.

#4 Updated by BitingBird over 4 years ago

  • Affected tool set to Installer

#5 Updated by intrigeri about 3 years ago

  • Blocked by deleted (Bug #8331: Merge liveusb-creator upstream changes)

#6 Updated by u about 1 year ago

#7 Updated by u about 1 year ago

  • Status changed from Confirmed to Rejected

Upstream is supposed to have fixed this. No news on this ticket with similar reports since 3 years. → closing.

#8 Updated by intrigeri about 1 year ago

  • Status changed from Rejected to Confirmed

Upstream is supposed to have fixed this.

I think there's a misunderstanding: with "upstream", back then we meant the original liveusb-creator code base we've forked 7 years ago. But we never brought these fixes to Tails Installer.

Also available in: Atom PDF